[Buildroot] [Bug 6122] iconv.h missing for charconv.c build

bugzilla at busybox.net bugzilla at busybox.net
Mon Jun 10 15:15:14 UTC 2013


--- Comment #4 from Andrew Scheller <uclibc-bugzilla at loowis.durge.org> 2013-06-10 15:13:28 UTC ---
I just had this bug too, but I dunno what caused it, and I dunno how to
reproduce it!

For some unknown reason I was getting a fatal error during the compilation of
dosfstools 3.0.16 about charconv.c trying to include iconv.h but being unable
to. I tried investigating, but couldn't work out what was going wrong (I'm not
that familiar with buildroot or cross-compilation setups). So I did 'rm -r
output/build/dosfstools-3.0.16' followed by a 'make' and I still got the same
error. So tried investigating again, but didn't get anywhere. So then I did 'rm
-r output/build/dosfstools-3.0.16; rm -r output/build/libiconv-1.14' and to my
great surprise this time the 'make' worked fine.
So I dunno how buildroot / dosfstools / libiconv got itself into this funny
situation, but everything is building fine again now, and I dunno how to
reproduce the problem.

Configure bugmail: https://bugs.busybox.net/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

More information about the buildroot mailing list