[Buildroot] [PATCH 1/1] pulseaudio : bump to version 4.0

Peter Korsgaard jacmet at uclibc.org
Thu Jun 6 20:41:37 UTC 2013


>>>>> "Jérémy" == Jérémy Rosen <jeremy.rosen at openwide.fr> writes:

 Jérémy> removes a patch that was integrated upstream
 Jérémy> Signed-off-by: Jérémy Rosen <jeremy.rosen at openwide.fr>
 Jérémy> ---
 Jérémy>  .../pulseaudio-compat-with-json-c-0.11.patch       |   26 --------------------

Then you should also drop the AUTORECONF. From pulseaudio.mk:

# One patch touches configure.ac. We unconditionnally need libglib2
# because configure.ac uses AM_GLIB_GNU_GETTEXT. This unconditionnal
# dependency can be removed once the patch is removed.
PULSEAUDIO_AUTORECONF = YES
PULSEAUDIO_DEPENDENCIES += libglib2

 Jérémy> +++ b/package/multimedia/pulseaudio/pulseaudio.mk
 Jérémy> @@ -3,7 +3,7 @@
 Jérémy>  # pulseaudio
 Jérémy>  #
 Jérémy>  ################################################################################
 Jérémy> -PULSEAUDIO_VERSION = 3.0
 Jérémy> +PULSEAUDIO_VERSION = 4.0
 Jérémy>  PULSEAUDIO_SITE = http://freedesktop.org/software/pulseaudio/releases/
 Jérémy>  PULSEAUDIO_INSTALL_STAGING = YES
 Jérémy>  PULSEAUDIO_CONF_OPT = \

>From http://www.freedesktop.org/wiki/Software/PulseAudio/Notes/4.0/ I
see that the gtk support now needs gtk 3.x, which we don't have in
buildroot, so the optional libgtk2 support should get removed.

It would also be good if you could add license info while you're at it.

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list