[Buildroot] AM3517 Neon, OpenGL & EGLFS support

Wojciech Sleńska wojciech.slenska at gmail.com
Thu Jun 6 17:16:17 UTC 2013


Hello Charles,

I didn't check this patch for current version of buildroot. It was
created some time before 2013.05. Sorry for that.

I noticed that there was some changes in libgles configuration in new
versions of buildroot.
In attachment you can find patch for buildroot 2013.05 and my .config file.

In config I used arago compiler, because I had some problems in past
with others compilers – maybe just for sure use arago. You can find it
here: http://software-dl.ti.com/sdoemb/sdoemb_public_sw/arago_toolchain/2011_09/index_FDS.html

Few minutes ago I made build and test this solution on my TI AM3517
and it is working.

Best Regards
Wojciech Slenska


2013/6/6 Charles Krinke <charles.krinke at gmail.com>:
> Dear Wojciech:
>
> I have been working with your patch but seem to have gotten myself
> into another "pickle" in that when I compile, I get the sequence
> below. I will start again fresh in the morning with the original patch
> and the nightly build from buildroot, which will be
> buildroot-20130606.tgz.
>
> Question, I presume the patch should apply against tonights buildroot?
> If not, is there a nightly build you would recommend for applying to
> patch to?
>
> If you have a suggestion on the errors, that would be appreciated.
>
> Hopefully you, Spenser or Prabu can get this and any remaining logic
> into buildroot so Neon, OpenGl and EGLFS support becomes part of the
> buildroot trunk, soon.
>
>>>> qt5base 5.0.2 Extracting
> xzcat /home/ckrinke/buildroot-20130605/dl/qtbase-opensource-src-5.0.2.tar.xz
> | tar --strip-components=1 -C
> /home/ckrinke/buildroot-20130605/output/build/qt5base-5.0.2  -xf -
>>>> qt5base 5.0.2 Patching package/qt5//qt5base
>
> Applying qt5base-mkspecs-files.patch using patch:
> patching file mkspecs/devices/linux-buildroot-g++/qmake.conf
> patching file mkspecs/devices/linux-buildroot-g++/qplatformdefs.h
>
> Applying qt5base-uclibc-no-lfs.patch using patch:
> patching file mkspecs/common/posix/qplatformdefs.h
>>>> libgles undefined Configuring
>>>> libgles undefined Building
>>>> libgles undefined Installing to target
>>>> libegl undefined Extracting
>>>> libegl undefined Patching package/opengl//libegl
>>>> libegl undefined Configuring
> echo "No libEGL implementation selected. Configuration error."
> No libEGL implementation selected. Configuration error.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: .config
Type: application/octet-stream
Size: 29255 bytes
Desc: not available
URL: <http://lists.busybox.net/pipermail/buildroot/attachments/20130606/13941175/attachment-0002.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-Qt5-EGL-for-OMAP-dirty-patch-for-builroot-2013.05.patch
Type: application/octet-stream
Size: 8785 bytes
Desc: not available
URL: <http://lists.busybox.net/pipermail/buildroot/attachments/20130606/13941175/attachment-0003.obj>


More information about the buildroot mailing list