[Buildroot] [PATCH] package/libbsd: depends on architectures providing a.out.h

Peter Korsgaard jacmet at uclibc.org
Wed Jun 5 19:00:17 UTC 2013


>>>>> "Yann" == Yann E MORIN <yann.morin.1998 at free.fr> writes:

 Yann> From: "Yann E. MORIN" <yann.morin.1998 at free.fr>
 Yann> libbsd requires a.out.h, which is only available in a select subset
 Yann> of the architectures Buildroot supports.

 Yann> This means libedit can no longer 'select' libbsd, so turn the 'select'
 Yann> into a 'depends on'. And the dependency chain ends there.

Why? You can just propagate the arch dependencies to libedit as well.
I don't like dependencies for libraries, it isn't obvious to people that
we actually have a libedit package.

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list