[Buildroot] [PATCH 23/67] libgail: libglib2 requires threads

Spenser Gilliland spenser at gillilanding.com
Mon Jul 15 19:47:06 UTC 2013


Signed-off-by: Spenser Gilliland <spenser at gillilanding.com>
---
 package/libgail/Config.in | 6 ++++++
 1 file changed, 6 insertions(+)

diff --git a/package/libgail/Config.in b/package/libgail/Config.in
index ba74795..3e1af62 100644
--- a/package/libgail/Config.in
+++ b/package/libgail/Config.in
@@ -1,5 +1,7 @@
 config BR2_PACKAGE_LIBGAIL
 	bool "libgail"
+	depends on BR2_USE_WCHAR # pango -> libglib2
+	depends on BR2_TOOLCHAIN_HAS_THREADS # pango -> libglib2
 	depends on BR2_PACKAGE_LIBGTK2
 	select BR2_PACKAGE_PANGO
 	help
@@ -16,3 +18,7 @@ config BR2_PACKAGE_LIBGAIL
 	  program.
 
 	  http://developer.gnome.org/projects/gap
+
+comment "libgail requires a toolchain with WCHAR and threading support"
+	depends on BR2_PACKAGE_LIBGTK2 && \
+		(!BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS)
-- 
1.8.1.2




More information about the buildroot mailing list