[Buildroot] Removing/solving gettext dependencies in libuio

Thomas De Schampheleire patrickdepinguin+buildroot at gmail.com
Tue Jul 30 12:28:05 UTC 2013


I'm adding the library libuio to buildroot
This library expects gettext to be present, but I want to avoid adding
this dependency to buildroot because it really isn't needed.

What is the best way to solve this?
The first alternative is to patch the package and remove the
problematic code. These changes are in configure.ac, Makefile.am, the
patch is fairly short. This change is not acceptable upstream (I

A second alternative is to change libuio to recognize --disable-nls.
However, I'm not sure how to do that.
The configure.ac file contains:


This macro is provided by gettext itself, so without gettext this doesn't work.
I tried something like:

AC_ARG_ENABLE([nls], AC_HELP_STRING([--disable-nls], [Do not use
Native Language Support]),
              USE_NLS=$enableval, USE_NLS=yes)


AS_IF([test "x$enable_nls" == xyes],

but I still get complaints about AM_GNU_GETTEXT not recognized.
I have tried finding good examples of implementing --disable-nls
without requiring gettext, but I can't find any.

Any input welcome,


More information about the buildroot mailing list