[Buildroot] [PATCH 2/2] libcurl: packages that use it need mmu also

Gustavo Zacarias gustavo at zacarias.com.ar
Thu Feb 14 13:50:56 UTC 2013


On 02/14/2013 10:47 AM, Thomas Petazzoni wrote:
> I don't agree. I believe the libcurl package should not depend on
> BR2_USE_MMU instead. I have a patch that I'll send as a reply to this
> e-mail.

Cool, i don't have much time to look into it so i went the fast route.
Careful though, 7.28.1 is security vulnerable and a bump to 7.29.0 is
necessary.
That said the bump doesn't build since it doesn't like macro definitions
in CFLAGS, it's probably safer to just patch the security vulnerability
since moving over the largefile defs to CPPFLAGS isn't probably clean at
this point in the upcoming release.
Regards.




More information about the buildroot mailing list