[Buildroot] multchoice menu with kconfig

Stefan Fröberg stefan.froberg at petroprogram.com
Mon Feb 18 16:32:43 UTC 2013

18.2.2013 18:23, Arnout Vandecappelle kirjoitti:
> On 18/02/13 17:16, Stefan Fröberg wrote:
>> 18.2.2013 18:08, Arnout Vandecappelle kirjoitti:
>>> >On 18/02/13 17:01, Stefan Fröberg wrote:
>>>> >>And because this iso-codes package does not seem to have nothing but
>>>> >>punch .po files
>>>> >>and not link against anything then changing that
>>>> >>to host-gettext should be good.
>>> >
>>> >  Err... But iso-codes doesn't need host-gettext, does it? It probably
>>> >doesn't make much sense without locale support in the toolchain, but
>>> >otherwise I see no dependencies except python (which is already a
>>> >buildroot dependency).
>>> >
>> But don't you need at least host gettext stuff to process those .po
>> files ?
>> I should now tell at this point that besides giving  -lintl linker flags
>> and giving --disable-nls to configure scripts
>> I absolutely have no idea how gettext works. :D
>> Im confused now.
>> So no dependencies at all ????? Or gettext dependencies with locale
>> checking ?????? (Like Thomas said in his post)
>  Sorry, correction: it does need host-gettext, but the gettext package
> (or rather, msgfmt) is one of our global dependencies.

Ah, I see.
So if it's only that msgfmt that is needed and it is already there then
I can remove ISO_CODES_DEPENDENCIES completely?

>  host-gettext is only needed for the autoconf macros (because we don't
> use the system's autoconf, only our own version).
>  Regards,
>  Arnout

Speaking of autoconf (or actually autoreconf):

I have a prelink package ready here and I had to do PRELINK_AUTORECONF =
YES what happens is that it complains about
missing ./ABOUT-NLS and ./config.rpath .
I tried to give PRELINK_AUTORECONF_OPTS = --install --force so that it
would create those missing files but it did not change anything.

The only thing that worked was doing the following horrible looking stuff:

    (cd $(@D); \


Im still using 2012.08 version of buildroot so could that be the reason
that buildroots autoreconf does not create those two missing files ?


More information about the buildroot mailing list