[Buildroot] [PATCH 08/15] package: remove useless arguments from AUTOTARGETS

Thomas Petazzoni thomas.petazzoni at free-electrons.com
Sat Sep 17 07:11:36 UTC 2011

Le Sat, 17 Sep 2011 08:36:17 +0200,
Peter Korsgaard <jacmet at uclibc.org> a écrit :

> Does those functions do the right thing here or do we need to rename
> the directory to libfuse?

Good catch: those functions make the assumption that the directory is
named after the name of the package. Actually, the name of the .mk is
not important to these macros, it is the directory name that is

+define pkgmakefile
+$(dir $(lastword $(MAKEFILE_LIST)))

For package/fuse/libfuse.mk, the output of this macro is package/fuse/.
In fact, I think we could rename this macro "pkgmakefiledir" or
something like that.

+define pkgname
+$(lastword $(subst /, ,$(call pkgmakefile)))

And therefore the output of this if "fuse". So you're correct that the
fuse package need to be changed.

Should I rebase my changes on master (to include new packages) and fix
those issues ?


Thomas Petazzoni, Free Electrons
Kernel, drivers, real-time and embedded Linux
development, consulting, training and support.

More information about the buildroot mailing list