[Buildroot] proc not mouning

Heyendal, Carl CHeyendal at stanleyworks.com
Thu Mar 24 19:04:09 UTC 2011


> -----Original Message-----
> From: buildroot-bounces at busybox.net [mailto:buildroot-
> bounces at busybox.net] On Behalf Of Thomas Petazzoni
> Sent: March 24, 2011 2:59 PM
> To: buildroot at busybox.net
> Subject: Re: [Buildroot] proc not mouning
> 
> Hello,
> 
> On Wed, 23 Mar 2011 16:35:16 -0400
> "Heyendal, Carl" <CHeyendal at stanleyworks.com> wrote:
> 
> > I was originally generating the root filesystem as a cpio archive and
> > using that to populate my SD card. Later on, as a build optimization,
> > I disabled generating rootfs.cpio at the top level Buildroot
> > menuconfig. Instead I started copying 'output/target/*' over to my SD
> > card. That's when the trouble began I guess. I switched back to using
> > rootfs.cpio to populate the SD card and I no longer have the
> > problem. :-)
> 
> >From the Buildroot documentation at
> http://buildroot.org/downloads/buildroot.html :
> 
>  target/ which contains almost the complete root filesystem for the
>  target: everything needed is present except the device files in /dev/
>  (Buildroot can't create them because Buildroot doesn't run as root and
>  doesn't want to run as root). Therefore, this directory should not be
>  used on your target. Instead, you should use one of the images built
> in
>  the images/ directory. If you need an extracted image of the root
>  filesystem for booting over NFS, then use the tarball image generated
>  in images/ and extract it as root.
> 
> Thomas
> --
> Thomas Petazzoni, Free Electrons
> Kernel, drivers, real-time and embedded Linux
> development, consulting, training and support.
> http://free-electrons.com
> _______________________________________________
> buildroot mailing list
> buildroot at busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot

Thanks for the RTFMS. :-)

/carl h.





More information about the buildroot mailing list