[Buildroot] Firmware Loading

Neal Peacock neal at coinfree.com
Thu Oct 21 21:03:19 UTC 2010


I realize this is kind of an old post but I think I'm having the same
trouble
with the carl9170 driver on my embedded system.  Could you post how you
setup udev to handle the firmware loading?  I tried echoing udevd into the
proc/sys/kernel/hotplug and all and I know I have the .sh script in place
but nothing seems to be happening and firmware loads always time out.

Thanks.

Andrew Wiley-2 wrote:
>
> On Sat, Jan 16, 2010 at 7:29 AM, Michael S. Zick
> <minimod at morethan.org>wrote:
>>
>> Perhaps update the mdev configuration file?
>> It ships empty, it has to, too installation specific to pre-define
>> anything.
>>
>> mdev --help
>> will start you off; continue as required with the command descriptions -
>> if loaded on your machine during the build or at the busybox web-site.
>>
>
> Well, I wound up just going with udev, call me lazy if you like, but it
> works for me. My board runs off a flash drive, so space isn't an issue. I
> won't generally be adding or removing devices after startup, so
> performance
> isn't really an issue either, but I may wind up swapping out devices that
> are connected at boot time, so udev seemed like a better solution for my
> setup.
>
> Thanks,
> Andrew
>
> _______________________________________________
> buildroot mailing list
> buildroot at busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
>



--
Neal Peacock
VP of Product Development
Coin Free LLC
407-657-5971



More information about the buildroot mailing list