[Buildroot] [git commit master] samba: only require libiconv if !BR2_ENABLE_LOCALE

Thomas Petazzoni thomas.petazzoni at free-electrons.com
Fri May 21 18:37:51 UTC 2010


commit: http://git.buildroot.net/buildroot/commit/?id=0317b30912eb73bc512b137b1581ff520b14c40a
branch: http://git.buildroot.net/buildroot/commit/?id=refs/heads/master

Signed-off-by: Thomas Petazzoni <thomas.petazzoni at free-electrons.com>
---
 package/samba/Config.in |    2 +-
 package/samba/samba.mk  |    2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/package/samba/Config.in b/package/samba/Config.in
index 720ecd7..a7a0b34 100644
--- a/package/samba/Config.in
+++ b/package/samba/Config.in
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_SAMBA
 	bool "samba"
-	select BR2_PACKAGE_LIBICONV
+	select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
 	help
 	  Provides print services to all manner of SMB/CIFS clients,
 	  including the numerous versions of Microsoft Windows
diff --git a/package/samba/samba.mk b/package/samba/samba.mk
index 4115363..39968a9 100644
--- a/package/samba/samba.mk
+++ b/package/samba/samba.mk
@@ -16,7 +16,7 @@ SAMBA_INSTALL_TARGET = YES
 
 
 SAMBA_DEPENDENCIES = \
-	libiconv \
+	$(if $(BR2_ENABLE_LOCALE),,libiconv) \
 	$(if $(BR2_PACKAGE_SAMBA_RPCCLIENT),readline) \
 	$(if $(BR2_PACKAGE_SAMBA_SMBCLIENT),readline) \
 	$(if $(BR2_PACKAGE_SAMBA_AVAHI),avahi) \
-- 
1.6.3.3




More information about the buildroot mailing list