[Buildroot] [git commit master] qt: ensure libglib2 is built before qt if enabled for Qt's glib support

Lionel Landwerlin llandwerlin at gmail.com
Fri Jan 15 20:35:37 UTC 2010


Le vendredi 15 janvier 2010 à 14:48 +0100, Peter Korsgaard a écrit :
> commit: http://git.buildroot.net/buildroot/commit/?id=8086dfa32fafb91102be5b7516088cde9f2b8699
> branch: http://git.buildroot.net/buildroot/commit/?id=refs/heads/master
> 
> Signed-off-by: Peter Korsgaard <jacmet at sunsite.dk>
> ---
>  package/qt/qt.mk |    5 +++++
>  1 files changed, 5 insertions(+), 0 deletions(-)
> 
> diff --git a/package/qt/qt.mk b/package/qt/qt.mk
> index 4b6876f..a3a466a 100644
> --- a/package/qt/qt.mk
> +++ b/package/qt/qt.mk
> @@ -48,6 +48,11 @@ else
>  QT_CONFIGURE+= -no-qt3support
>  endif
>  
> +# ensure glib is built first if enabled for Qt's glib support
> +ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
> +QT_DEP_LIBS+=libglib2
> +endif
> +
>  
>  ### Pixel depths
>  QT_PIXEL_DEPTHS := # empty

Hi Peter,

There is also an option in the Qt configuration for glib integration. It
would be nice to have access to it through KConfig.

--
Lionel




More information about the buildroot mailing list