[Buildroot] MTD build failing: undefined ref's to bcopy, bcmp

Grant Edwards grant.b.edwards at gmail.com
Thu Jan 7 17:57:48 UTC 2010


On 2010-01-07, Thomas Petazzoni <thomas.petazzoni at free-electrons.com> wrote:
> Le Thu, 7 Jan 2010 17:02:31 +0000 (UTC),
> Grant Edwards <grant.b.edwards at gmail.com> a ??crit :
>
>> I patched the bug in the mtd package so it's now building, but
>> it won't run:
>> 
>>    # flash_info
>>    flash_info: can't load library 'libgcc_s.so.1'
>> 
>> libgcc_s.so.1 appears in the staging directory,
>> 
>>    $ find . -name libgcc_s*
>>    ./output/staging/usr/arm-linux-uclibc/lib/libgcc_s.so
>>    ./output/staging/usr/arm-linux-uclibc/lib/libgcc_s.so.1
>> 
>> but it's not present in the target filesystem.
>
> Are you using a buildroot-generated toolchain or an external toolchain ?

Yes. :)

It's an external toolchain that was generated by buildtoot.

I can try using an "internal" toolchain, but that approach
really slows down work since each "guess" takes 40-50 minutes
instead of 10-12.

>> Am I having all of these problem becuase I shouldn't be using
>> HEAD, or am I doing something else wrong?
>
> The MTD utils package has very recently been updated into HEAD, which
> might explain why you're encountering so many failures.
>
>   http://git.buildroot.net/buildroot/commit/?id=9400c73582326c543fae82120af3904836145655
>
> Thomas


-- 
Grant Edwards                   grante             Yow! Gee, I feel kind of
                                  at               LIGHT in the head now,
                               visi.com            knowing I can't make my
                                                   satellite dish PAYMENTS!



More information about the buildroot mailing list