[Buildroot] Make 3.82 does behave differently than make 3.81 for sure, but ...

James J. Dines jdines at jdines.net
Mon Aug 30 21:10:00 UTC 2010

Hash: SHA1

On 08/30/2010 04:57 PM, Peter Korsgaard wrote:
>>>>>> "James" == James J Dines <jdines at jdines.net> writes:
> Hi,
>  James> I am really interested to hear your results, because I just
>  James> bought this new 8 core machine and set it up this weekend.  So
>  James> far everything has worked great, but there is always this
>  James> nagging worry that I have something set up wrong and I will have
>  James> to post back to the list stating that I was an idiot and missed
>  James> something :-)
>  James> In any case, untarring buildroot-2010.05, doing a make defconfig
>  James> followed by a make clean seems like a set of steps that should
>  James> go off without a hitch (it certainly does on my other machine)
>  James> but it fails with make 3.82 for me anyway :-(
>  James> [jdines at hydra buildroot-2010.05 ] make clean
>  James> package/atk/atk.mk:43: *** recipe commences before first target.  Stop.
> Yeah, that's the bug in atk.mk Yann fixed earlier today. Could you give
> git a try instead (either git clone or wait for tomorrows snapshot
> tarball).

I went for a third option (applying Yann's patch) and it indeed allows
the 'make clean' to work.  I remain confused why we did not need this
patch to do a complete build with make 3.81 however.  I just tried it
again, and I do not get the error message on my other machine with 3.81
even without the patch.
Version: GnuPG v1.4.10 (GNU/Linux)


More information about the buildroot mailing list