[Buildroot] [PATCH] CUPS requires stack protection support

root thiago.correa at gmail.com
Wed May 13 21:43:26 UTC 2009


Signed-off-by: Thiago A. Correa <thiago.correa at gmail.com>
---
 package/cups/Config.in |    4 ++++
 1 files changed, 4 insertions(+), 0 deletions(-)

diff --git a/package/cups/Config.in b/package/cups/Config.in
index 8b1f8a5..27611e1 100644
--- a/package/cups/Config.in
+++ b/package/cups/Config.in
@@ -1,6 +1,10 @@
 config BR2_PACKAGE_CUPS
 	bool "cups"
+	depends on BR2_USE_SSP
 	help
 	  The Common Unix Printing System
 
 	  http://www.cups.org
+
+comment "cups requires a toolchain with Stack Protection support"
+	depends on !BR2_USE_SSP
-- 
1.6.0.6




More information about the buildroot mailing list