[Buildroot] Need some help with uClibc build

Maxim Grigoriev maxim at tensilica.com
Wed Jan 21 17:13:40 UTC 2009


Thanks for your advice, Peter.

You suggest to keep it simple - the latest versions of the tools
and libraries are the best to try.

I will switch to uclibc 0.9.30 and gcc 4.3.2.

-- Maxim


Peter Korsgaard wrote:
>
>  Maxim> Can somebody, please, help me.
>  Maxim> I seem to be missing something trivial like the fact that
>  Maxim> gcc-4.3.1+ would not work with uClibc-0.9.29, or something
>  Maxim> like this.
>
> That could very well be - uClibc 0.9.29 is old, and gcc 4.3.x is
> pretty new.
>
>  Maxim> I'm trying to build buildroot with
>
>  Maxim>     binutils-2.19
>  Maxim>     uClibc-0.9.29
>  Maxim>     gcc-4.3.1
>
> Why would you want to use those versions instead of the stable and
> recommended ones? (uclibc 0.9.30, gcc 4.3.2)?
>
>   




More information about the buildroot mailing list