[Buildroot] svn commit: trunk/buildroot/package/qte

Peter Korsgaard jacmet at uclibc.org
Fri Jan 30 10:56:26 UTC 2009


>>>>> "laird" == laird  <laird at uclibc.org> writes:

 laird> Author: laird
 laird> Date: 2009-01-30 10:49:59 +0000 (Fri, 30 Jan 2009)
 laird> New Revision: 25162

 laird> Log:
 laird> qte.mk: Use depends on for toolchain features 

 laird> Buildroot is adopting depends on for toolchain features and
 laird> select for packages. Make this change in this file.
 
 laird> Signed-off-by: Daniel Laird <daniel.j.laird at nxp.com>

 laird> @@ -2,7 +2,7 @@
 laird>  	bool "Qt/E"
 laird>  	depends on BR2_DEPRECATED
 laird>  	depends on BR2_INSTALL_LIBSTDCPP
 laird> -	select BR2_PTHREADS_NATIVE
 laird> +	depends on BR2_PTHREADS_NATIVE
 laird>  	select BR2_PACKAGE_JPEG
 laird>  	select BR2_PACKAGE_LIBPNG
 laird>  	help

You forgot to update comment so people can know how to enable it:

comment "Qt/E requires a toolchain with C++ support enabled"
        depends on !BR2_INSTALL_LIBSTDCPP
        depends on BR2_DEPRECATED

That one should depend on !BR2_PTHREADS_NATIVE and the text should get
updated.

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list