[Buildroot] PXA270 and gcc-4.3.3 for iwMMXt

Daniel Mack daniel at caiaq.de
Wed Apr 22 16:14:56 UTC 2009

On Wed, Apr 22, 2009 at 09:08:28AM -0700, Laine Walker-Avina wrote:
> I've been trying to build a busybox system with buildroot for a
> PXA270-based system. I tried to use the latest gcc version in svn to
> generate the kernel and rootfs, however when I try to run the system I
> can't login and it doesn't run any of the init scripts in init.d. I
> tried to chroot to the new rootfs from a previously built rootfs
> compiled for a armv4 arch and it gave me a "Illegal Instruction" error
> when trying to run ash. Most other commands from that busybox run
> fine. And ash runs fine if i don't do the chroot and use the shared
> libs from the other rootfs. Any thoughts?

Check that your kernel and toolchain binaries are both built for EABI
and check for the following entries in your busybox .config:

# BR2_ARM_OABI is not set

What you describe to see is very likely that kind of problem, we had
that many times already. The above settings should do well, though.


More information about the buildroot mailing list