[Buildroot] Error building qt-embedded in buildroot-20080618 snapshot

Thiago A. Corrêa thiago.correa at gmail.com
Sat Jun 28 03:59:58 UTC 2008


Hi Simone,

   I have just commited to svn the qtopia improvements that were sitting in
the google tree. I tried out the x86 build and it worked ok. Since you are
using snapshots, it might take a day or so for it to show up in there, but
it should work ok now.

Kind Regards,
    Thiago A. Correa


On Fri, Jun 20, 2008 at 2:39 PM, Thiago A. Corrêa <thiago.correa at gmail.com>
wrote:

> Hi Simone,
>
>    I'm able to build qt-embedded for avr32 using the googlecode
> buildroot, and actually use it in custom packages. I do know for a
> fact that upstream buildroot qtopia/qt-embedded is quite broken, but I
> don't recall of issues in it that would cause this problem in
> particular.
>
>    Others have seen problems with pthreads in newer uClibc, you might
> want to try 0.9.28 instead. I will try to build x86 qt-embedded on my
> tree to see if it works as well.
>
> Kind Regards,
>    Thiago A. Correa
>
>
> On Fri, Jun 20, 2008 at 12:38 PM, Simone Calamai
> <simone.calamai at gmail.com> wrote:
> > Hello,
> > I am trying to build buildroot with the qt-embedded in the
> > buildroot-20080618 snapshot on a Ubuntu 8.04 system
> > for a i386 target (Vortex86SX board).
> > In the configuration step, I enabled the support for Qtopia4 in Package
> > Selection/Graphics Libraries
> > section, then modified uClibc-0.9.29.config to set
> > # UCLIBC_HAS_STDIO_GETC_MACRO is not set
> > # UCLIBC_HAS_STDIO_PUTC_MACRO is not set
> > to avoid an 'undefined reference to '__fgetc_unlocked'" error just at the
> > beginning of qt-embedded build.
> >
> > The qt build goes on but it is finally stopped with this error:
> >
> > g++ -fno-exceptions -o ../../../bin/uic3
> > .obj/release-shared-emb-x86/customwidgetsinfo.o
> > .obj/release-shared-emb-x86/databaseinfo.o
> > .obj/release-shared-emb-x86/driver.o
> > .obj/release-shared-emb-x86/treewalker.o
> .obj/release-shared-emb-x86/ui4.o
> > .obj/release-shared-emb-x86/uic.o .obj/release-shared-emb-x86/validator.o
> > .obj/release-shared-emb-x86/cppextractimages.o
> > .obj/release-shared-emb-x86/cppwritedeclaration.o
> > .obj/release-shared-emb-x86/cppwriteicondata.o
> > .obj/release-shared-emb-x86/cppwriteicondeclaration.o
> > .obj/release-shared-emb-x86/cppwriteiconinitialization.o
> > .obj/release-shared-emb-x86/cppwriteincludes.o
> > .obj/release-shared-emb-x86/cppwriteinitialization.o
> > .obj/release-shared-emb-x86/main.o
> .obj/release-shared-emb-x86/ui3reader.o
> > .obj/release-shared-emb-x86/parser.o
> .obj/release-shared-emb-x86/domtool.o
> > .obj/release-shared-emb-x86/object.o
> > .obj/release-shared-emb-x86/subclassing.o
> .obj/release-shared-emb-x86/form.o
> > .obj/release-shared-emb-x86/converter.o
> > .obj/release-shared-emb-x86/widgetinfo.o
> .obj/release-shared-emb-x86/embed.o
> > .obj/release-shared-emb-x86/qt3to4.o .obj/release-shared-emb-x86/deps.o
> >
> -L/media/CLFS/build/buildroot-20080619/build_i386/qt-embedded-linux-opensource-src-4.4.0/lib
> > -lQt3Support
> >
> -L/media/CLFS/build/buildroot-20080619/build_i386/qt-embedded-linux-opensource-src-4.4.0/lib
> > -lQtSql -lQtXml -lQtGui -lQtNetwork -lQtCore -lm -lrt -ldl -lpthread
> >
> >
> /media/CLFS/build/buildroot-20080619/build_i386/qt-embedded-linux-opensource-src-4.4.0/lib/libQt3Support.so:
> > undefined reference to `_res'
> >
> /media/CLFS/build/buildroot-20080619/build_i386/qt-embedded-linux-opensource-src-4.4.0/lib/libQtCore.so:
> > undefined reference to `__glibc_strerror_r'
> > collect2: ld returned 1 exit status
> > make[2]: *** [../../../bin/uic3] Error 1
> > make[2]: Leaving directory
> >
> `/media/CLFS/build/buildroot-20080619/build_i386/qt-embedded-linux-opensource-src-4.4.0/src/tools/uic3'
> > make[1]: *** [sub-uic3-make_default-ordered] Error 2
> > make[1]: Leaving directory
> >
> `/media/CLFS/build/buildroot-20080619/build_i386/qt-embedded-linux-opensource-src-4.4.0'
> > make: ***
> >
> [/media/CLFS/build/buildroot-20080619/build_i386/qt-embedded-linux-opensource-src-4.4.0/.compiled]
> > Error 2
> >
> > Is there anybody that has successfully built the buildroot system with
> the
> > above described features ?
> > If so, please tell me which is the correct procedure
> >
> > Thank you all
> >
> > Simone
> >
> >
> >
> > _______________________________________________
> > buildroot mailing list
> > buildroot at uclibc.org
> > http://busybox.net/mailman/listinfo/buildroot
> >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.busybox.net/pipermail/buildroot/attachments/20080628/4c5b1d71/attachment-0002.htm 


More information about the buildroot mailing list