[Buildroot] svn commit: trunk/buildroot/package/busybox

Peter Korsgaard jacmet at uclibc.org
Fri Jun 27 14:07:07 UTC 2008


>>>>> "sjhill" == sjhill  <sjhill at realitydiluted.com> writes:

[resent with stripped to: to please mailman
]
Hi,

 >> > Daniel> I use buildroot actively in my company and have kept up to
 >> > Daniel> date pretty well.  However we are still using busybox 1.2.2.1
 >> 
 >> And what's the reason for you doing this? Do you like huge .bss and just
 >> don't want to benefit from the improvements that went into busybox
 >> during the last years?
 >> 

 sjhill> Because some applets work in 1.2.2.1 that don't in newer
 sjhill> versions, like telnetd for example.

Ohh, what's the problem? I don't use it myself, but openwrt afaik uses
it on 1.8.x

 >> If there are regressions (something worked with 1.2.2.1 but fails with
 >> 1.11.0) no matter if they are behavioural or size-regressions, then you
 >> would be better off to report those to the busybox list.
 >> 

 sjhill> Some of us live in the real world where once we ship a
 sjhill> product and start providing updates, it becomes cost
 sjhill> prohibitive to requalify all the software on a platform to
 sjhill> make sure everything still plays together.

So I guess you freeze your buildroot snapshot as well?

A missing 1.2.2.1 should only be a problem for people starting new
development and wanting to use 1.2.2.1 (which they shouldn't) - right?

 >> >So you are still doing active development (E.G. buildroot stuff) on a
 >> >project where you cannot change the busybox version? 
 >> >
 >> > Daniel> So I vote for not removing just deprecating :-)
 >> >
 >> >Ok, anyone still using 1.6 .. 1.8?
 >> 
 sjhill> I vote for deprecating.

Ok, noted.

But this is bigger than just busybox ofcause - It also goes for all
other packages.

-- 
Bye, Peter Korsgaard



More information about the buildroot mailing list