[Buildroot] cris

Ralph Siemsen ralphs at netwinder.org
Wed Jul 30 02:39:53 UTC 2008

On Mon, Jun 23, 2008 at 04:54:09PM +0200, Hinko Kocevar wrote:
> I think that other arches are not affected as long as the whole need for headers goes (haven't really tried out). It is kernel bug in cris port that can't handle the headers for arch-v10 and arch-v32 correctly. So once the Axis has complete solution in order to pull all required headers from the source tree this problems will vanish.

I'm compiling from GIT targeting ARM and ran into some of the same
problems as discussed in this thread.  Specifically:
 - missing limits.h
 - changing "extern" to "static" in libpthread
I was able to make things work by adapting patches posted here (Thanks!).
eg. patch sysdeps/arm/pt-machine.h instead of cris version

I ran into an additional issue when I enabled soft-float toolchain,
there was a problem linking mpfr, somehow /usr/lib/libgmp.so from my
i386 host machine is pulled instead of the ARM target version.  I
don't have a clean solution for this one, but I was able to manually
link mpfr against the correct libgmp.so


More information about the buildroot mailing list