[Buildroot] Buildroot for AT91RM9200-EK?

J. L. Sloan jsloan at diag.com
Tue Jul 29 22:23:00 UTC 2008


Just to make sure I'm not spinning my wheels, has anyone gotten Buildroot
(22987 is what I'm using right now) working for the Atmel AT91RM9200-EK
board (Atmel AT91 ARM9)?

 

I've got the 2.6.25.10 kernel booting okay, but as soon as it goes to run
/init (really, busybox) wackiness ensues. It traps in clear_user trying to
zero out part of the loaded ELF. GDB+BDI suggests that the address passed
from padzero to clear_user is bogus, but I'm not sure I'm trusting what it's
telling me (some of the other stuff on the stack trace looks questionable).

 

readelf-h suggests AFAIK that everything is built as OABI. (I may restart
from the beginning with EABI, but I'm not sure how U-Boot on the EK was
built, and I'm not sure if that really matters. But U-Boot does "call" the
kernel to start it.)

 

Thanks for any insight.

 

--

John Sloan <http://www.diag.com/navigation/metadata/jsloan.html>
Consulting Technologist

jsloan at diag.com          Digital Aggregates Corporation
<http://www.diag.com/> 

+1 303 489 5178 (Mobile) Arvada
<http://www.google.com/maps?f=q&hl=en&geocode=&q=Arvada+Colorado&ie=UTF8&z=1
1&iwloc=addr&om=1>  Colorado 80001-0587 USA

+1 303 940 9064 (Office) www.diag.com <http://www.diag.com/> 

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.busybox.net/pipermail/buildroot/attachments/20080729/fc346d0d/attachment-0002.htm 


More information about the buildroot mailing list