[Buildroot] buildroot for armeb, gcc-4.2.1 fails to build

Hamish Moffatt hamish at cloud.net.au
Tue Oct 16 06:44:09 UTC 2007

On Tue, Oct 16, 2007 at 08:00:07AM +0200, Ulf Samuelsson wrote:
>> And this is caused by soft-float.
>> Summary of situation:
>> arm EABI hard-float: builds.
>> armeb EABI hard-float: libgcc_s.so fails to link due to incorrect file
>> format of libc.so
>> arm/armeb OABI hard-float: builds.
>> arm/armeb OABI soft-float: fails as above (both endians fail the same
>> way).
>> I haven't tried soft-float EABI.
> I tried the ARM integrator, on Bernhards recommendation
> a few weeks ago, and that would build an EABI 4.2.1 softfloat toolchain,
> a few days later, it was broken again.
> I think that there must be some uClibc options which should be set
> in the correct way for the build to complete.

I just built arm + EABI + soft-float + 4.2.1 successfully.
I'm trying armeb now, although I'm not hopefully given that the same
configuration except for soft-float failed (with non-float-related

Hamish Moffatt VK3SB <hamish at debian.org> <hamish at cloud.net.au>

More information about the buildroot mailing list