[Buildroot] newbie comment/question

James L Henrickson jim.henrickson at critical.com
Mon Jan 29 05:02:04 UTC 2007

I downloaded BuildRoot according to the documentation, tried to jump 
ahead but failed, then went back to the documentation and found that a 
default build failed too.  The problem was that the latest uclibc 
snapshot failed to build.  I got over that by falling back to the 
uclibc.x.x.1 option instead.  (This had worked when I tried to jump 
ahead, but my attempt to build for an i486 target then failed on some 
sort of missing kernel patch target.)  OK, with this i686 build complete 
(after falling back to an earlier version of uclibc), I was unable to 
find a kernel to load onto my target.  I didn't see this problem 
documented anywhere.  How do I compile (or cross-compile, since my goal 
is to use BuildRoot as a cross-platform development tool if possible) a 
kernel image under BuildRoot?  Is this outside the scope of BuildRoot?  
I just came over from OpenEmbedded because their support for uclibc 
seems to be deficient, and I didn't see any mention of kernel building 
in the BuildRoot docs.  Any help would be appreciated.


More information about the buildroot mailing list