[Buildroot] Building x86_64 failes

Bernhard Fischer rep.dot.nop at gmail.com
Fri Jan 19 15:08:06 UTC 2007

On Fri, Jan 19, 2007 at 02:31:53PM +0100, Goetz Bock wrote:
>Dear list,
>after I've successfully build buildroot for i586 on my
>amd64/debian/sarge box, I wanted to build the same rootfs for amd64.
>So I copied the existing buildroot, removed build_i586 and
>toolchain_build_i586, ran make clean and make menuconfig to
>reconfigureit for x86_64.
>But building the toolchain failes with:
>In function 'x86_fallback_frame_state':
>error: 'struct sigcontext' has no member named 'esp'
>. [ more missing e?? members ]

Can you check that uClibc has the correct arch set?
>It does not matter what version of binutils/gcc I use, it's always the
>same error.
>(I've tried binutuils: 2.16.1, 2.17,, and gcc
>4.0.3, 4.1.1, 4.2)
>The i386 realy irritates me, and I've no idea where it comes from.

The config/i386 is ok

What kernel-headers do you use?

hm. Could it be that you try to compile a 32bit x86-64 compiler? For the
64bit, there is definately no (resp. shouldn't be a) esp.

More information about the buildroot mailing list