[Buildroot] libmad-0.15.1b fails on build

Simon Pasch fpasch at googlemail.com
Fri Aug 24 10:26:24 UTC 2007

Libmad fails to build for x86 (likely for other architectures too)
because of the avr32-optimization-patch.

If you don't intend to build libmad for avr32, simply removing the patch helps.

Perhaps it would make sense to make the patch depend on the chosen
architecture. Don't know how this is solved in other packages. I tried
it with the folowing patch. (To keep the patch simple I manually
renamed the file "libmad-0.15.1b-avr32-optimization.patch" to

--- buildroot.old/package/libmad/libmad.mk	2007-08-24 09:15:35.000000000 +0200
+++ buildroot/package/libmad/libmad.mk	2007-08-24 12:10:43.000000000 +0200
@@ -16,6 +16,9 @@
 $(LIBMAD_DIR)/.unpacked: $(DL_DIR)/$(LIBMAD_SOURCE)
+ifeq ($(strip $(BR2_avr32)),y)
+	toolchain/patch-kernel.sh $(LIBMAD_DIR) package/libmad/
 	toolchain/patch-kernel.sh $(LIBMAD_DIR) package/libmad/
 	touch $@

Didn't have the time...but it seems, that the mplayer-package has some
avr32-only optimizations too

More information about the buildroot mailing list