[Buildroot] [PATCH] Fix sed fail when building qtopia

Thiago A. Corrêa thiago.correa at gmail.com
Mon Aug 20 23:42:15 UTC 2007


Ops, didn't send the msg to the list, sorry. Perhaps one could
consider changing the default reply to the list rather than to the
poster.

Oh, btw, this patch fixes bug 0001457, please apply and close the
issue on the bugtracker. Thanks :)

---------- Forwarded message ----------
From: Thiago A. Corrêa <thiago.correa at gmail.com>
Date: Aug 20, 2007 7:36 PM
Subject: Re: [Buildroot] [PATCH] Fix sed fail when building qtopia
To: Bernhard Fischer <rep.dot.nop at gmail.com>


Yes, much better indeed. And it works fine now. At least that part so far :)

After that, I get a link error building moc, haven't figured that one yet.

I have attached the patch updated, thanks.

Cheers,
    Thiago A. Correa


On 8/20/07, Bernhard Fischer <rep.dot.nop at gmail.com> wrote:
> On Mon, Aug 20, 2007 at 07:00:17PM +0100, Thiago A. Corrêa wrote:
> >Hi there,
> >
> >   This patch should fix the error:
> >   sed: -e expression #1, char 21: unknown option to `s'
> >
> >   I am sure there is a better way to do this, but I'm not comfortable
> >with shell scripts enough, so, if someone has a better solution, by
> >all means :)
>
> ergh, that's rather ugly.
> Please try to use this instead and let me know if that works for you:
> $(SED) 's,-O2,$(TARGET_CFLAGS),' \
> $(QTOPIA4_TARGET_DIR)/mkspecs/qws/linux-$(BR2_PACKAGE_QTOPIA4_EMB_PLATFORM)-g++/qmake.conf
>
> (i.e. use ',' instead if '/'.
>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: fix-qtopia.patch
Type: application/octet-stream
Size: 1426 bytes
Desc: not available
URL: <http://lists.busybox.net/pipermail/buildroot/attachments/20070821/456632e0/attachment-0003.obj>


More information about the buildroot mailing list