[Buildroot] configure is never called from Makefile.autotools.in

Bernhard Fischer rep.dot.nop at gmail.com
Fri Aug 24 14:01:45 UTC 2007

On Fri, Aug 24, 2007 at 03:38:01PM +0200, Simon Pasch wrote:
>x11r7-building fails with current snapshot because of commit 19657
>"if $(PKG)_SKIP_CONFIGURE is non-empty then ./configure is skipped"
>doesn't seem to work.
>Instead ./configure is never called...Although I tried playing around
>with the variable LIBXCB_SKIP_CONFIGURE, etc.

Could be. I'll back it out since autotools packages always have a
configure (as opposed to the package i tried to build with the
autotools.in file).

Sorry for the inconvenience..

I'm not 100% happy with Makefile.autotools.in, btw:
rp-pppoe, for example, has it's configure not in the toplevel dir but in
src/. From the looks, the autotools.in can't cope with such a layout,

Furthermore, for all autotools packages, it is easily possible to build
outside of the sourcetree, so stepping into an empty build_dir and
calling $(PKG)_CONFIGURE_DIR/configure ... (where this would default to
just the $(PKG)_DIR) would be nice, mid-term (think project_build

>Just by the way...You do a great job here...Fast and reliable. It is a
>pleasure to work with buildroot, uclibc, busybox!

nice to hear. Thanks for your kind words :)


More information about the buildroot mailing list