[Buildroot] [patch] kernel-headers: lzma causing issues

Brad House brad at mainstreetsoftworks.com
Wed Aug 15 11:51:55 UTC 2007


>> +config BR2_KERNEL_HEADERS_LZMA
>> +	bool "use lzma initramfs kernel patches"
>> +	default y
>> +	help
>> +	  Apply patches which allow for lzma compressed
>> +	  initramfs filesystems.  This requires the lzma
>> +	  program in your development environment.	
>> +
> 
> Since it also breaks unless you have lzma causing headache, 
> I think the default should be to not use the lzma patch...

ok, yeah, I'd agree with that ... I was just maintaining
compatibility for those who are using it by defaulting to y.

> I am working on a new scheme where the target/linux and
> toolchain/kernel-headers are integrated, but this
> needs a lot more testing and will (as agreed with Bernhard
> be reviewed before applied, but it seems reasonable
> to do this as an intermediate fix.

Ah, yeah, it would definitely make sense for those to be
integrated. It took me a minute to realize the kernel
headers version is what determined which release of the
kernel got built ;)

Thanks.
-Brad



More information about the buildroot mailing list