[uClibc] ld.so loading "false" libs

Erik Andersen andersen at codepoet.org
Tue Sep 28 18:24:39 UTC 2004


On Sun Sep 26, 2004 at 04:37:52PM +0200, Joakim Tjernlund wrote:
> Well, anybody using X in glibc without ldso cache will also break.
> Possibly one could add /usr/X11R6/lib to dl-elf.c iff cache is disabled to make
> the transition easier, but I think it is better to break apps now rather than later.
> 
> Yes, I also think the non RUNTIME items in dl-elf.c should go.
> 
> I think the cache should be forced to /lib and /usr/lib first instead, otherwise
> you don't have any use of the cache for /lib and /usr/lib and that sort of defeats the
> purpose of the cache in the first place.
> 
> Erik?

Hmm.  I've always had cache support disabled, which is why
/usr/X11R6/lib is present.  You will notice there is no config
option to enable the ldso cache at present.  Anyway, I do _NOT_
think we should be gratuitously changing this at this time,
especially not to accomodate a function that has always been
disabled...

What I think should be done is

    *) Someone that cares about USE_CACHE should fix that option
	up to be sure it works, and give it a proper config entry
	in extra/Configs/Config.in, and rename it to something
	more appropriate such as LDSO_CACHE_SUPPORT.

    *) When LDSO_CACHE_SUPPORT=n, UCLIBC_RUNTIME_PREFIX /usr/X11R6/lib
	should be included in the default library search path in
	dl-elf.c, ldd, and ldconfig.

    *) When LDSO_CACHE_SUPPORT=y, UCLIBC_RUNTIME_PREFIX /usr/X11R6/lib
	should be excluded from the default library search path in
	dl-elf.c, ldd, and ldconfig, and those wishing to include
	X11 stuff should add that into /etc/ld.so.conf and re-run
	ldconfig.

    *) At present, LDSO_CONF and LDSO_CACHE use the same names
	and same structure as glibc.  This precludes
	LDSO_CACHE_SUPPORT being uses in any sane fashion on a
	dial glibc and uClibc system.  Just as it was necessary
	for use to use a different name for 'libuClibc' rather
	than 'libc', and 'ld-uClibc.so.0' rather than
	'ld-linux.so.2' it seems that these configuration files
	really ought to be given different names.

 -Erik

--
Erik B. Andersen             http://codepoet-consulting.com/
--This message was written using 73% post-consumer electrons--



More information about the uClibc mailing list