BusyBox ash as subshell for mc (midnight commander)?

Alexander Kriegisch kriegaex at freetz.org
Thu Mar 1 16:24:42 UTC 2012

[re-send to list because reply-to header was wrong as usual]

Sorry, I wanted to send my message to the list, but the reply-to was
wrong - it has been annoying me for a long time on that list. Depending
on who answers the messages, you have to be careful to use "reply to
all". :-(

ralda at gmx.de, 01.03.2012 14:45:
>> No matter if I use this script or CONFIG_FEATURE_BASH_IS_ASH, mc
>> does not like the pseudo-bash. It starts up, but as soon as I
>> execute the first command, mc exits. The command - e.g. "ls -l /"
>> or whatever - gets executed, but afterwards mc shuts down with
>> "exit 0". If you like to see an strace, I can send one if it is not
>> too off-topic.
>> I tried the same thing with a real bash binary replacing the
>> symlink to busybox, and mc subshell support immediately works as
>> expected - same busybox and mc binaries.
>> Any ideas?
> It is some time since I used ash wit mc ... as far as I know mc
> depends on the fancy prompt features. May be you even have to enable
> full blown desktop features (unsure if anything of ash depends on
> this). just enable all those ash features in Busybox. In addition you
> may need to fiddle with your (prompt) settings (some work with mc
> others not).
> Let me know if that works for you ... else I need to dig into some 
> bigger archives (old hard disk backups) to fiddle that out. I know
> it worked and it was simple after I found how it works, but I did it
> the hard way and got a bit confused (so I don't want to tell
> something wrong).

Anyway, fancy prompt is active and does not help. To use full desktop
settings is not an option in my embedded environment. I would appreciate
if you found out what exactly needs to be configured in BB or patched in
MC in order to get this to work.

Thanks in advance
Alexander Kriegisch (kriegaex)

More information about the busybox mailing list