login

David Henderson dhenderson at digital-pipe.com
Tue Jan 11 14:02:08 UTC 2011


David Henderson wrote:
> bump for help
>
>
> David Henderson wrote:
>> I'm back with yet another question - thanks to all of those who've 
>> been patient and provided help thus far.  I'm working on the actual 
>> login aspect of the distro at this point, but have been running into 
>> problems using some of the applets provided in busybox.  I'm sure 
>> they're user error, but here we go...
>>
>> I initially tried to copy the /etc/passwd, shadow, group, and gshadow 
>> files from my working Kubuntu distro to busybox (after recompiling 
>> without pam support).  I figured it wouldn't work, and it failed as I 
>> suspected.  What I decided to do, at this point, was get to a prompt 
>> and create those files using the applets from busybox so there'd be 
>> no issues.  Below is what I tried to do and the errors that were given:
>>
>> # cd /etc
>> # rm group gshadow passwd shadow
>> # touch group gshadow passwd shadow
>> # addgroup -g 0 root
>> # addgroup users
>> # cat group
>> root:x:0:
>> users:x:1000:
>> # adduser -h /root -s /bin/bash -G root -u 0 root
>> adduser: unknown group root
>> # adduser -h /home/dave -s /bin/bash -G users dave
>> adduser: unknown group users
>>
>> I read online that busybox may not work well with GID's and UID's 
>> outside of the range specified in it's configuration (mine was set to 
>> start at 100 and end at 999 by default).  So I was expecting issues 
>> adding and working with the root account as it's UID and GID are 0.  
>> However, busybox added the "users" group as 1000 (outside the range 
>> specified in its config) and still gives errors when trying to use 
>> it.  Any ideas?
>>
>> Dave

UPDATE: Talking with another mailing list member, it appears as though 
the UID/GID numbering issue isn't an issue at all.  However, I'm still 
at a loss as to why this isn't working.  As stated, I've tried using the 
group gshadow, passwd, and shadow files from another distro without 
success as well as creating them with busybox applets.  addgroup seems 
to have no issues, but adduser always fails with messages listed above.  
I've tried using the passwd and shadow files from other distros and just 
change the password, but I end up with a "passwd: unknown uid 0" error.  
I've verified that I have /lib/libcrypt (and /lib/gcrypt) even though 
running ldd against the busybox binary doesn't specify that it needs 
those libs.  It just will not work and I don't know why.  Is this 
perhaps a misleading error message in busybox?  Am I missing a lib 
somewhere?

Dave


More information about the busybox mailing list