lsmod

Denys Vlasenko vda.linux at googlemail.com
Sun Jan 9 19:58:53 UTC 2011


On Friday 07 January 2011 20:28, Gilles Espinasse wrote:
> > Sorry to bombard the mailing list with so many questions...  I've run
> > into another issue.  I'm attempting to get networking going on my
> > distro, but came across a strange situation.  I tried checking what
> > hardware was being detected so I ran busybox's lspci which gave ID's and
> > classes along with numbers instead of written descriptions so I can't
> > tell what is what.  Is this typical behavior for busybox's lspci?  I
> > then tried to see which modules were installed (lsmod), but got no
> > output, just another prompt.  Surely I have to have some drivers
> > installed!  I then tried to load the e1000e driver for the NIC (which
> > was verified in an existing distro that fully works).  Trying to "insmod
> > e1000e" resulted in "insmod: can't read 'e1000e': No such file or
> > directory".  And trying to "modprobe e1000e" produced "modprobe:
> > 'kernel/drivers/net/e1000e/e1000e.ko.gz': invalid module format."
> > However, that module does in fact exist and it's for the kernel taken
> > from a working distro with the driver located under
> > /lib/modules/*kernel*/kernel/drivers/net/e1000e.  Any ideas?
> >
> > Dave
> 
> insmod need full path and does not support compressed module.
> 
> The fact that you had ''kernel/drivers/net/e1000e/e1000e.ko.gz' show that
> /lib/modules/*kernel*/modules.dep is available
> 
> 'invalid module format' is only in modprobe-small code.
> Probably select the complete modprobe to have compressed module support.
> That's what I use and that work.

Meanwhile I'll fix modprobe-small to work with compressed modules.

-- 
vda


More information about the busybox mailing list