lsmod

David Henderson dhenderson at digital-pipe.com
Fri Jan 7 16:57:18 UTC 2011


Sorry to bombard the mailing list with so many questions...  I've run 
into another issue.  I'm attempting to get networking going on my 
distro, but came across a strange situation.  I tried checking what 
hardware was being detected so I ran busybox's lspci which gave ID's and 
classes along with numbers instead of written descriptions so I can't 
tell what is what.  Is this typical behavior for busybox's lspci?  I 
then tried to see which modules were installed (lsmod), but got no 
output, just another prompt.  Surely I have to have some drivers 
installed!  I then tried to load the e1000e driver for the NIC (which 
was verified in an existing distro that fully works).  Trying to "insmod 
e1000e" resulted in "insmod: can't read 'e1000e': No such file or 
directory".  And trying to "modprobe e1000e" produced "modprobe: 
'kernel/drivers/net/e1000e/e1000e.ko.gz': invalid module format."  
However, that module does in fact exist and it's for the kernel taken 
from a working distro with the driver located under 
/lib/modules/*kernel*/kernel/drivers/net/e1000e.  Any ideas?

Dave


More information about the busybox mailing list