getty

David Henderson dhenderson at digital-pipe.com
Fri Jan 7 16:46:45 UTC 2011


Thanks for the reply Harald.  I tried doing that, but ran into 
problems.  First, I'm using runit instead of standard init which breaks 
things down into three stages (1=boot, 2=running system, 
3=shutdown|reboot).  I can successfully get to a prompt if I add "exec 
/bin/bash" as the final line in stage 1, however, stage 2 is never 
reached which is obviously where I need to be so that daemons and other 
startup scripts can be executed.  If I add that line into one of the 
scripts in stage 2, runit just keeps spawning an instance of the bash 
causing prompt after prompt to be generated.  The other problem I 
noticed, is that if I place the "exec getty -i ..." (as shown below) in 
stage 1, I also get a login prompt, but no stage 2.  Shouldn't I just be 
getting a shell prompt and not a login prompt since I'm passing those 
parameters to getty?
>
> Thanks,
> Dave
>
>
> Harald Becker wrote:
>>  Hallo David!
>>
>> Why don't you start directly a shell session, if it's a local line? What
>> do you want to achieve in a more global fashion?
>>
>> Harald
>>
>> On 07.01.2011 14:09, David Henderson wrote:
>>  
>>> bump for help
>>>
>>>
>>> David Henderson wrote:
>>>    
>>>> I'm trying to get several terminals setup on a custom distro and are
>>>> starting them with the following line (using runit):
>>>>
>>>> exec getty -i -n -t 0 -L 115200 tty1
>>>>
>>>> However, I still get timed out after 60 seconds and I'm being
>>>> prompted for a username.  The system isn't setup for multi-user yet,
>>>> hence the -n for "don't prompt the user for a login name" and -t 0
>>>> for no timeout.  Also, if I'm specifying -L (for local line), do I
>>>> still need to provide a baud rate?
>>>>
>>>> Thanks,
>>>> Dave
>>>>       
>>> _______________________________________________
>>> busybox mailing list
>>> busybox at busybox.net
>>> http://lists.busybox.net/mailman/listinfo/busybox
>>>     


More information about the busybox mailing list