[PATCH] Support for the LOWER_UP flag

Natanael Copa natanael.copa at gmail.com
Thu Jun 5 15:07:34 UTC 2008


On Thu, 2008-06-05 at 16:56 +0200, Denys Vlasenko wrote:
> On Thursday 05 June 2008 16:54, Natanael Copa wrote:
> > > Applied, thanks. (It also brought my attention to ~300+ bytes
> > > of bloat nearby, which I removed).
> > 
> > oh.... I guess we were working on the same thing then.
> > 
> > I'm attatching what I was looking at. I guess it does not apply anymore.
> 
> Not at all, I just removed some useless dances with fprintf(fp, ...)
> which were invariably printing to stdout. You are working on something
> different, so please continue :)

I'm done with it more or less (and my day is over). I think the patch i
posted in previous email need testing though. It touches (too?) many
places.

basicly it replaces:

if (flags & mask) 
	printf("FLAG ");

with a "mask_string" struct (better name anyone?) and print_flags()
func:

flag_struc = { 
	{ mask, "FLAG" },
	{ 0, NULL }
};

...
print_flags(flag_struc, flags, " ");
...

There seems to be a drawback on places where the mask and flags is a
byte rahter than int. But it reduces text as showed in the previous
posted 'make bloatcheck'.

Please have a look at it.

Thanks!


> --
> vda




More information about the busybox mailing list