[PATCH] watchdog add settimeout ioctl

Bernhard Fischer rep.dot.nop at gmail.com
Tue Aug 12 11:06:51 UTC 2008


On Wed, Aug 06, 2008 at 11:20:10AM +0300, Darius wrote:

> #define OPT_FOREGROUND 0x01
>-#define OPT_TIMER      0x02
>+#define OPT_STIMER      0x02
>+#define OPT_HTIMER      0x03

>+	if (opts & OPT_STIMER) {

>+	if (opts & OPT_HTIMER)

I did not look closely, but it sounds like this will not work like you
intend.

Generally it's less error prone and furthermore easier to read
(IMO) if you say:

#define OPT_FOREGROUND	(1<<0)
#define OPT_STIMER	(1<<1)
#define OPT_HTIMER	(1<<2)

please fix, test and resend for inclusion.
Thanks!



More information about the busybox mailing list