ssh +openpty

Rob Landley rob at
Tue Mar 28 19:26:52 UTC 2006

On Tuesday 28 March 2006 2:35 am, Marc Leeman wrote:
> I have some strange problem that leaves me kind of puzzled: I tried to
> upgrade our systems from busybox 1.1.0 to 1.1.1 yesterday and when
> trying to log in to the systems with dropbear, the following appears in
> the logs:
> Dec 31 17:00:45 scorpius authpriv.warn dropbear[148]: pty_allocate:
> openpty: No such file or directory Dec 31 17:00:45 scorpius authpriv.warn
> dropbear[148]: no pty was allocated, couldn't execute Dec 31 17:05:19
> scorpius dropbear[148]: exit after auth (root): received data
> with bad writefd
> The change to busybox is the only change in the system. If I replace the
> busybox file with the 1.1.0 all works as it has for months.

Sounds like /dev/pts isn't getting mounted.

> If I start my NFS system with 1.1.0 and after that, replace it with the
> 1.1.1; the login is fine.
> I don't understand what busybox 1.1.0 does differently with pty's that
> 1.1.1 does not _before_ login :-/

The init scripts probably call "mount -a".  That had a lot of work done on it, 
which I'm pretty sure fixed more things than it broke, and I ran an extensive 
regression test suite against it (testsuite/mount.testroot), but testing's no 
substitute for users actually trying it.

> The one 'relevant' post I saw dates from before 1.1.1 and quotes a 'fix'
> in the kernel to 'solve' the problem; in my case, it must be busybox
> that does something differently.

Look at what mount -a is doing with your /etc/fstab.  If I can understand or 
reproduce it, I'll fix it.

Never bet against the cheap plastic solution.

More information about the busybox mailing list