insmod broken in 1.1.1

Jason Schoon floydpink at gmail.com
Fri Mar 24 20:00:04 UTC 2006


Jean Wolter posted about this to the mailing list yesterday...


On 3/24/06, Bernhard Fischer <rep.nop at aon.at> wrote:
> On Fri, Mar 24, 2006 at 07:50:50PM +0100, stephane.billiart wrote:
> >I tried to upgrade my system today with busybox and realized
> >that insmod systematically fails with the messages:
> >insmod: ELF file not for this architecture
> >insmod: Could not load the module: Success
> >
> >I added some debug output and saw that the error comes from
> >line 3334 of modutils/insmod.c because of ELFDATAM is
> >wrongly set on line 519 because BB_LITTLE_ENDIAN is
> >not defined (although I am on a P3 compiling for an Elan processor
> >which are little endians).
> >
> >I haven't looked at how BB_LITTLE_ENDIAN is supposed to be
> >calculated but there's apparently something wrong there.
> >I am not sure how to best fix this so I'm asking the list first.
> >
> >In 1.1.0 everything worked ok and the test was
> >#if __BYTE_ORDER == __LITTLE_ENDIAN
>
> This was broken by Robert P. J. Day and apparently ci by Rob:
> http://busybox.net/lists/busybox/2006-March/019043.html
>
> Robert, this has come up before, iirc, but i don't seem to see a patch
> which corrects this?
>
> _______________________________________________
> busybox mailing list
> busybox at busybox.net
> http://busybox.net/cgi-bin/mailman/listinfo/busybox
>



More information about the busybox mailing list