[git commit] Announce 1.23.0

Denys Vlasenko vda.linux at googlemail.com
Wed Dec 24 00:54:42 UTC 2014


commit: http://git.busybox.net/busybox-website/commit/?id=4f32868580c7273bbc46cea5c733f6e69433cfe4
branch: http://git.busybox.net/busybox-website/commit/?id=refs/heads/master

Signed-off-by: Denys Vlasenko <vda.linux at googlemail.com>
---
 news.html |  280 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 files changed, 280 insertions(+), 0 deletions(-)

diff --git a/news.html b/news.html
index 27a0586..1f50e15 100644
--- a/news.html
+++ b/news.html
@@ -31,6 +31,286 @@
     </p>
   </li>
 
+  <li><b>23 December 2014 -- BusyBox 1.23.0 (unstable)</b>
+    <p><a href="http://busybox.net/downloads/busybox-1.23.0.tar.bz2">BusyBox 1.23.0</a>.
+    (<a href="http://git.busybox.net/busybox/tree/?h=1_23_stable">git</a>,
+    <a href="http://busybox.net/downloads/fixes-1.23.0/">patches</a>,
+    <a href="http://busybox.net/fix.html">how to add a patch</a>)</p>
+
+    <p>Sizes of busybox-1.21.1 and busybox-1.22.0 (with equivalent config, static uclibc build):<pre>
+   text	   data	    bss	    dec	    hex	filename
+ 873357	    489	   7072	 880918	  d7116	busybox-1.22.1
+ 876323	    490	   7072	 883885	  d7cad	busybox-1.23.0</pre>
+    </p>
+
+    <p>Changes since previous release:
+<pre>
+Aaro Koskinen (2):
+      less: make -E work
+      install: implement -t DIR
+
+Ari Sundholm (2):
+      df: implement -T option
+      df: fix -T option when ENABLE_FEATURE_HUMAN_READABLE=0
+
+Bartosz Golaszewski (17):
+      gitignore: ignore files generated by 'make test'
+      sort: remove a magic number from compare_keys()
+      sort: check global flags on fallback sort
+      ntpd: fix compilation warnings
+      top: fix compilation warnings
+      grep: properly handle grep -w "^str" in !EXTRA_COMPAT case too
+      Kbuild: move CONFIG_PAM to general configuration
+      shuf: fix a segfault on 'shuf -e'
+      shuf: improve help text
+      docs: update new-applet-HOWTO.txt
+      find: add optional support for '-exec ... {} +'
+      libbb: use a wrapper around sysconf(_SC_CLK_TCK) to save a few bytes
+      unit-tests: implement the unit-testing framework
+      Rename INIT_LAST to INIT_FUNC to avoid confusion
+      gitignore: add testsuite/echo-ne
+      libbb: use sendfile() to copy data between file descriptors
+      Config: select PLATFORM_LINUX if using sendfile()
+
+Baruch Siach (2):
+      nandwrite: fix build when long options are disabled
+      nanddump: don't show --bb in usage when disabled
+
+Bernhard Reutner-Fischer (1):
+      libbb: provide usleep() fallback implementation
+
+Cristian Ionescu-Idbohrn (1):
+      tail: adjust help/usage texts
+
+David Marchand (1):
+      modinfo: fix module parsing with kernel >= 2.6.37
+
+Denys Vlasenko:
+      *: add conditional support for -v / --verbose
+      *: exit with 127 if applet name wasn't found - it's more POSIXy
+      ash,hush: do not segfault on $((2**63 / -1))
+      ash,hush: fix a thinko about 2^64-1 factorization
+      ash,hush: improve randomness of $RANDOM, add easy-ish way to test it
+      ash,hush: run reinit_unicode() only if makes sense
+      ash,hush: set $HOSTNAME is bash compat. Closes 7028
+      ash: factor out ASH_HELP config option
+      ash: fix handling of negative start value in ${v:start:len}
+      ash: fix off-by-one in "jobs %4" handling. closes 7310
+      ash: in bash compat mode, always export $SHLVL
+      ash: make "local VAR" unset VAR (bash does that)
+      ash: make ${#var} unicode-aware
+      awk: fix handling of "if ... break ; else ..." - closes 7226
+      crond: implement "SHELL=prog" in crontab. Export LOGNAME as POSIX wants
+      crond: simplify logging code
+      du, copy_file: fix file matching on cramfs. Closes 5456
+      fakeidentd: simplify ndelay manipulations
+      false: make "false --help" exit with 1
+      find: exit code fixes for find -exec
+      find: fix a regression introduced with -HLP support
+      find: support -perm /BITS. Closes 7340
+      find: use sysconf(_SC_ARG_MAX) to determine the command-line size limit
+      ftpd: do not use root_fd if we are not in chroot
+      ftpd: escape chroot prior to re-executing ls helper
+      ftpd: for LIST, open current directory *in the child*
+      ftpd: make LIST command show dotfiles too
+      ftpd: support deprecated XPWD command
+      getty: set tty attrs so that control chars are shown as ^c
+      grep: fix "grep -r PATTRN SYMLINK_TO_DIR"
+      grep: fix -w match if first match isn't a word, but second is. Closes 4520
+      grep: fix two bugs with -w
+      hush: make "true" built-in
+      hush: make ${#var} unicode-aware
+      hwclock: fix setting of tz_minuteswest. Closes 5414
+      init: do not run shutdown/reexec actions from signal handler
+      init: if libc-based Unicode support is on, run setlocale(LC_ALL, "") at startup
+      ip link: add support for "address ETHADDR". Closes 4862
+      less: accept and ignore -s
+      less: disable "suppress empty wraparound" optimization
+      less: fix bugs discovered with "git log -p | less -m" on kernel tree
+      less: move "retry-on-EAGAIN" logic closer to read ops
+      libarchive: add capability to unpack to mem.buffer
+      libarchive: open_zipped() does not need to check extensions for e.g. gzip
+      libbb/obscure.c: code shrink. Suggested by Tito.
+      libbb: FreeBSD fix for B<num> baud rate constants not fitting into a short
+      libbb: don't die if crypt() returns NULL
+      libbb: fix a bad check for uclibc >= 0.9.31
+      libbb: fix bb_ask() to flush input before prompt, not after. Closes 7190
+      libbb: fix compile failure if both ARG_MAX and _SC_ARG_MAX are defined
+      libbb: fix empty PATH components handling
+      libbb: fix parsing of "10101010" date/time form
+      libbb: fix thinko in rtc_xopen()
+      libbb: if opening /dev/loopN returns ENXIO, don't try N++
+      libbb: make rtc_xopen try harder on EBUSY
+      libbb: make syslog level for bb_error_msg's configurable. use it in crond
+      libbb: open_zipped() should not fail on non-compressed files
+      libbb: use ARG_MAX for bb_arg_max() only if it's 60k+
+      lineedit: don't fall back to simple line input if tty is in raw mode
+      ls: make "ls -s DIR" show total too. Clases 4946
+      lzop: add overflow check
+      make xmalloc_open_zipped_read_close result NUL terminated
+      man: accept a list of dirs in $MANPATH
+      man: default to ascii
+      man: do not mangle $MANPATH in memory
+      mdev: treat zero-length /dev/mdev.seq the same as "\n" one. Closes 7334
+      modprobe,rmmod: reject module names with slashes
+      modprobe-small: (un)load all modules which match the alias, not only first one
+      modprobe-small: fix help messages for aliased module-related applets
+      modprobe-small: fix safe_strncpy truncating last char of module name
+      modprobe-small: remove redundant aliases from modules.dep.bb
+      nc: fix option bit positions. Closes 6926
+      networking/ssl_helper: experimental matrixssl-based ssl helper
+      networking: explain isrv_run() API
+      ntpd: add optional support for /etc/ntp.conf
+      ntpd: add support for -I IFACE
+      ntpd: adjust last packet's recv time after a step
+      ntpd: be less eager to use shorter poll intervals
+      ntpd: fix wrong delay value in one of the printed messages
+      ntpd: remove now unnecessary check for IP_PKTINFO definition
+      ntpd: truly ignore high delay packet
+      ping: revert "try SOCK_DGRAM if no root privileges"
+      platform.h: undef HAVE_STRCHRNUL only on correct versions of FreeBSD
+      rtcwake: fix incorrect (reversed) rtc/sys adjuestment; code shrink
+      script: make it work even if fd 0 is closed
+      sed: fix "sed CMD -i nonexistent_file". Closes 7484
+      sed: fix a buglet in s///NUM handling
+      sendmail: make -f optional, document its default value
+      sha3: add 32-bit optimized bit-sliced implementation
+      sha3: code shrink (and speedup for SHA3_SMALL=0)
+      shuf: new applet
+      sysctl: do not error out showing write-only data. Closes 6386
+      syslogd: make "-O -" log to stdout
+      tar: fix "tar -cJ" ignoring -J option. closes 7706
+      tar: tighten up pax header validity check
+      taskset: fix logic error in "if it doesn't start with 0x..."
+      taskset: support CPU masks for more than 64 CPUs
+      test: fix mishandling of "test '(' = '('" and similar
+      tftpd: support full 512-byte requests
+      tftpd: tweak HP PA-RISC firmware bug compatibility
+      top: fix memset length (sizeof(ptr) vs sizeof(array) problem)
+      trylink: emit names of linked executables
+      ubiupdatevol: fix -t to not require an option. Closes 7466
+      udhcpc: account for script run time
+      udhcpc: don't use BPF filter, users report problems (bugs 4598, 6746)
+      udhcpc: fix BPF filter. Hopefully fixes the root cause of 4598 and 6746
+      udhcpc: ignore NAKs from "wrong" servers. Closes 4267
+      udhcpc: in comments, explain the kind of raw socket we create
+      udhcpc: make hostname sanitization optional. Closes 3979
+      udhcpd: if a lease from lease file coincides with a static one, ignore it
+      vi: clear undo buffer when we change to another file
+      vi: fix incorrect memory access on brace matching. Closes 7256
+      wget: add commented-out code to use ssl_helper instead of openssl
+      wget: add support for https using "openssl s_client" as a helper
+      wget: fix a case where progress bar isn't updated if writes are very slow
+      wget: fix use-after-free of ->user. Closes 6836
+      xargs: add support for -I and -i. Closes 493
+      zcat: complain if input is not compressed
+
+Drew Moseley (1):
+      build system: specify '-nostldlib' when linking to .o files
+
+Eugene Rudoy (1):
+      iplink: fix build with kernel versions prior to 2.6.23
+
+Florian Fainelli (1):
+      ping: add -p to specify data pattern
+
+Isaac Dunham (1):
+      unlink: new applet
+
+Jacob Kjaergaard (1):
+      flashcp: change BUFSIZE to 4k
+
+Jeremy Kerr (1):
+      udhcp: add PXELINUX path prefix option (code 210) definition
+
+Jody Bruchon (1):
+      vi: undo support for vi with intermediate queuing
+
+John Spencer (1):
+      man: parse "DEFINE pager" in config
+
+Joshua Judson Rosen (5):
+      syslogd: avoid spurious ftrunctate() calls for "-b 0"
+      syslogd: remember to un-writelock log-files even when called with "-b 0"
+      syslogd: Unify unlink/truncate + unlock log-rotation logic
+      syslogd: syslogd: don't *decrement* log_file->size on write failures
+      syslogd: make "reopen log file every second" logic work for multiple logs
+
+Kaarle Ritvanen (2):
+      ifupdown: support 'link' address family
+      sendmail: use FQDN in default envelope sender
+
+Ken Sharp (1):
+      zcip: fix link-local IP conflict detection
+
+Matt Whitlock (3):
+      avoid calling bb_strtou twice in MIN macro expansion
+      fix interaction of -a and -p options in swapon
+      add discard option -d to swapon
+
+Matthias Andree (1):
+      build system: fix non-portable sed constructs.
+
+Michael Gernoth (1):
+      stat: fix printing selinux context and null-dereference
+
+Michael Tokarev (3):
+      testsuite: fix last "which" change
+      init: do not fail build if SIGPWR is not defined
+      iproute: support onelink route option and print route flags
+
+Michel Stam (3):
+      udhcpd: add option for tweaking arpping
+      zcip: allow our own class B range to be used for ZeroConf
+      zcip: Add environment variable for overriding log functionality
+
+Mike Frysinger (2):
+      uname: fix up usage documentation
+      appletlib: fix set-but-unused warning
+
+Miroslav Lichvar (4):
+      ntpd: don't wait for good offset before disabling burst mode
+      ntpd: split out poll adjusting code
+      ntpd: don't stay at short polling interval
+      ntpd: calculate offset to jitter ratio before updating jitter
+
+Morten Kvistgaard (1):
+      ftpd: add optional support for authentication
+
+Pascal Bellard (1):
+      fatattr: new applet
+
+Peter Kümmel (1):
+      Make it possible to override LOGIN_FAIL_DELAY in CONFIG_EXTRA_CFLAGS
+
+Richard Genoud (4):
+      nanddump: correct rounding to next page (lead to infinite loop)
+      nanddump: add options --bb=skipbad and padbad
+      nanddump: kill -b Omit bad block
+      nanddump: change default to --bb=skipbad
+
+Romain Naour (1):
+      su: add a delay if the password is incorrect
+
+Ron Yorston (1):
+      lineedit: don't block when looking for escape sequence in vi-mode
+
+Ryan Mallon (1):
+      fakeidentd: fix use-after-free
+
+Timo Teräs (2):
+      which: rewrite
+      top: fix and merge code to parse /proc/meminfo
+
+Tito Ragusa (4):
+      adduser,addgroup: introduce and use CONFIG_LAST_ID
+      swapon/swapoff: size reduction, cleanup, fixes, improvements
+      swapon/swapoff: -a returns 0 on ignored errors
+      which: rewrite
+</pre>
+    </p>
+  </li>
+
   <li><b>20 January 2014 -- BusyBox 1.22.1 (stable)</b>
     <p><a href="http://busybox.net/downloads/busybox-1.22.1.tar.bz2">BusyBox 1.22.1</a>.
     (<a href="http://git.busybox.net/busybox/tree/?h=1_22_stable">git</a>,


More information about the busybox-cvs mailing list