[BusyBox 0001092]: mkfs.ext3 errors.

bugs at busybox.net bugs at busybox.net
Wed Jan 3 22:18:54 UTC 2007


The following issue has been CLOSED 
====================================================================== 
http://busybox.net/bugs/view.php?id=1092 
====================================================================== 
Reported By:                giffordj
Assigned To:                BusyBox
====================================================================== 
Project:                    BusyBox
Issue ID:                   1092
Category:                   Documentation
Reproducibility:            always
Severity:                   block
Priority:                   normal
Status:                     closed
Resolution:                 open
Fixed in Version:           
====================================================================== 
Date Submitted:             11-16-2006 14:28 PST
Last Modified:              01-03-2007 14:18 PST
====================================================================== 
Summary:                    mkfs.ext3 errors.
Description: 
When using mkfs.ext3, get several errors. Could not create journal, Could
not determine if /dev/hda1 is mounted

Actual dump of errors
mkfs.ext3 /dev/hda1
mke2fs 1.38 (30-Jun-2005)
mkfs.ext3: Could not determine if /dev/hda1 is mounted
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
1221600 inodes, 2441494 blocks
122074 blocks (5.00%) reserved for the super user
First data block=0
75 block groups
32768 blocks per group, 32768 fragments per group
16288 inodes per group
Superblock backups stored on blocks:
        32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632
Writing inode tables: done
Creating journal (32768 blocks): mkfs.ext3: Could not create journal

====================================================================== 

---------------------------------------------------------------------- 
 rockeychu - 11-16-06 17:19  
---------------------------------------------------------------------- 
I got the same problem before. It seems that you has not /etc/mtab. Just
use following cmd, and it's OK:
    touch /etc/mtab 

---------------------------------------------------------------------- 
 vda - 11-21-06 06:36  
---------------------------------------------------------------------- 
Wonderful. ext2fs_add_journal_inode() doesn't bother to print WHY it fails. 

---------------------------------------------------------------------- 
 vda - 01-03-07 14:18  
---------------------------------------------------------------------- 
Won't fix for now. Entire e2fsprogs is (temporary?) disabled except for few
simpler applets. If it ever to return back, someone needs to put it on
sanitizing diet. 

Issue History 
Date Modified   Username       Field                    Change               
====================================================================== 
11-16-06 14:28  giffordj       New Issue                                    
11-16-06 14:28  giffordj       Status                   new => assigned     
11-16-06 14:28  giffordj       Assigned To               => BusyBox         
11-16-06 17:19  rockeychu      Note Added: 0001742                          
11-21-06 06:36  vda            Note Added: 0001758                          
01-03-07 14:18  vda            Status                   assigned => closed  
01-03-07 14:18  vda            Note Added: 0001956                          
======================================================================




More information about the busybox-cvs mailing list