[BusyBox 0000153]: Upgrade from 0.61 to 1.00 on powerpc

bugs at busybox.net bugs at busybox.net
Fri Sep 2 03:07:04 UTC 2005


A NOTE has been added to this issue. 
====================================================================== 
http://busybox.net/bugs/view.php?id=153 
====================================================================== 
Reported By:                valkyr
Assigned To:                BusyBox
====================================================================== 
Project:                    BusyBox
Issue ID:                   153
Category:                   Documentation
Reproducibility:            always
Severity:                   crash
Priority:                   normal
Status:                     assigned
====================================================================== 
Date Submitted:             03-14-2005 07:43 PST
Last Modified:              09-01-2005 20:07 PDT
====================================================================== 
Summary:                    Upgrade from 0.61 to 1.00 on powerpc
Description: 
For a project I am working on it was necessary to upgrade to 1.00. I used
the same .config file for 1.00 as starting point for configuring. The
problem I ran into is that my system that worked flawlessly on 0.61
crashes on boot. It shows me a lot of errors while loading drivers (see
additional info). 
I found out that using telnetd forces you to use the SUID option. Has that
something to do with it?

I also miss some documentation on how to use a login strategy on busybox.
At this point it feels like a needle in the haystack to me.
====================================================================== 

---------------------------------------------------------------------- 
 landley - 09-01-05 20:07  
---------------------------------------------------------------------- 
What exactly do you want us to do with a bug report like this?  Is this a
bug report you expect us to be able to follow up on?

It looks like this boils down to "Bug submitter has no idea how to
configure busybox 1.00 for his system".  There's a reason the major
version number changed.  Off the top of my head:

You have modules refusing to load, although if this was a problem with
insmod why did the first half-dozen modules load fine?  You could have a
module dependency issue, or you might need to run depmod or some such (and
use modprobe instead of insmod).  I don't know, I haven't seen your setup. 
(I don't even know if you upgraded modules at the same time you upgraded
busybox.)

There's nothing wrong with cat; the file under /proc it's trying to look
at isn't there.  I don't know what the deal is with your /proc.  Is it
even mounted?  Is whatever driver that was supposed to create this file
one of the modules that refused to load?

"date" is telling you what's wrong with it.  It doesn't like the command
line arguments you're passing.

The next line is something bad happening in your shell script, but the
printout doesn't give enough information to say what.

And so on, and so forth...

Problem exists between keyboard and chair.  (If this had been posted to
the mailing list instead of the bug system, we'd have been much more
likely to be able to help...) 

Issue History 
Date Modified   Username       Field                    Change               
====================================================================== 
03-14-05 07:43  valkyr         New Issue                                    
03-16-05 12:27  andersen       Assigned To              andersen => BusyBox 
09-01-05 20:07  landley        Note Added: 0000485                          
======================================================================




More information about the busybox-cvs mailing list