<div dir="ltr">All,<br><div class="gmail_extra"><br><br><div class="gmail_quote">2013/11/4 Thomas De Schampheleire <span dir="ltr"><<a href="mailto:patrickdepinguin@gmail.com" target="_blank">patrickdepinguin@gmail.com</a>></span><br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi,<br>
<div class="im"><br>
On Mon, Nov 4, 2013 at 9:26 AM, Thomas Petazzoni<br>
<<a href="mailto:thomas.petazzoni@free-electrons.com">thomas.petazzoni@free-electrons.com</a>> wrote:<br>
> Dear Arnout Vandecappelle,<br>
><br>
> On Mon, 04 Nov 2013 08:10:07 +0100, Arnout Vandecappelle wrote:<br>
><br>
>>   I like the idea. We would typically do this with some auxiliary<br>
>> variables instead of a new download method, but maybe the download method<br>
>> isn't such a bad idea. It would add even more complexity to the horrible<br>
>> <a href="http://pkg-download.mk" target="_blank">pkg-download.mk</a>, though...<br>
>><br>
>>   Bottom line: the idea is good, but let's see if the implementation can<br>
>> be acceptable.<br>
><br>
> Instead of a new download method, can it simply be a helper function,<br>
> like:<br>
><br>
> FOO_SITE = $(call github,<user>,<package>,<version>)<br>
><br>
> or something like that. This way we don't clutter the core of the<br>
> download infrastructure with another site method that isn't really a<br>
> site method.<br>
<br>
</div>I'm ok with this suggestion.<br></blockquote><div><br></div><div>I like this too.</div><div><br></div><div>Regards,</div><div><br></div></div>-- <br>Samuel
</div></div>