<div><br></div>maybe a silly question.....have you tested your kernel/build via NFS....ie "tftp boot uImage" & "NFS mount rootfs"?<div><br></div><div><br><div><div><br><div class="gmail_quote">On Wed, Mar 23, 2011 at 9:00 PM, Torsten Mohr <span dir="ltr"><<a href="mailto:tmohr@s.netic.de">tmohr@s.netic.de</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">Hello,<br>
<br>
i've set up a micro SD card with VFAT on partition 1, EXT2 on partition 2.<br>
<br>
Partition 2 is buildroot's output/images/rootfs.ext2, copied with "dd" to the<br>
micro SD card.<br>
<br>
On partition 1 i have u-boot and i start the kernel like this:<br>
mmc init<br>
mmc rescan 0<br>
run loaduimage<br>
bootm 0x82000000<br>
<br>
Then i see the kernel boot log and i see it hanging:<br>
<br>
[    1.215850] twl_rtc twl_rtc: setting system clock to 2000-01-01 00:05:25<br>
UTC (946685125)<br>
[    1.226806] Waiting for root device /dev/mmcblk0p2...<br>
[    1.369873] mmc0: host does not support reading read-only switch. assuming<br>
write-enable.<br>
[    1.389953] mmc0: new SDHC card at address e624<br>
---> no more output<br>
<br>
<br>
I use buildroot-2011.02, the kernel is 2.6.37.<br>
<br>
In the kernel configuration i have set:<br>
<br>
TI OMAP Multimedia Card Interface support (MMC_OMAP)<br>
TI OMAP High Speed Multimedia Card Interface support (MMC_OMAP_HS)<br>
<br>
<br>
Can anybody give me a hint why the kernel does not continue to boot?<br>
<br>
<br>
Best regards,<br>
Torsten.<br>
<br>
_______________________________________________<br>
buildroot mailing list<br>
<a href="mailto:buildroot@busybox.net">buildroot@busybox.net</a><br>
<a href="http://lists.busybox.net/mailman/listinfo/buildroot" target="_blank">http://lists.busybox.net/mailman/listinfo/buildroot</a><br>
</blockquote></div><br></div></div></div>