<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
<META NAME="Generator" CONTENT="MS Exchange Server version 6.5.7653.38">
<TITLE>alsa-utils and nctp troubles with 2011.02</TITLE>
</HEAD>
<BODY>
<!-- Converted from text/plain format -->

<P><FONT SIZE=2>Hi,<BR>
<BR>
I have encountered some problems during my file system creation with buildroot 2011.02.<BR>
<BR>
- the first one was about alsa-utils install part :<BR>
<BR>
>>> alsa-utils 1.0.23 Installing to target<BR>
for i in usr/sbin/alsactl usr/bin/alsamixer usr/bin/amixer usr/bin/aplay usr/bin/speaker-test; do install -D -m 755 /home/ldesroches/buildroot_old/buildroot-2011.02/output/host/usr/arm-unknown-linux-uclibcgnueabi/sysroot/$i /home/ldesroches/buildroot_old/buildroot-2011.02/output/target/$i; done<BR>
if [ -x "/home/ldesroches/buildroot_old/buildroot-2011.02/output/target/usr/bin/speaker-test" ]; then mkdir -p /home/ldesroches/buildroot_old/buildroot-2011.02/output/target/usr/share/alsa/speaker-test; mkdir -p /home/ldesroches/buildroot_old/buildroot-2011.02/output/target/usr/share/sounds/alsa; cp -rdpf /home/ldesroches/buildroot_old/buildroot-2011.02/output/host/usr/arm-unknown-linux-uclibcgnueabi/sysroot/usr/share/alsa/speaker-test/* /home/ldesroches/buildroot_old/buildroot-2011.02/output/target/usr/share/alsa/speaker-test/; cp -rdpf /home/ldesroches/buildroot_old/buildroot-2011.02/output/host/usr/arm-unknown-linux-uclibcgnueabi/sysroot/usr/share/sounds/alsa/* /home/ldesroches/buildroot_old/buildroot-2011.02/output/target/usr/share/sounds/alsa/; fi<BR>
if [ -x "/home/ldesroches/buildroot_old/buildroot-2011.02/output/target/usr/sbin/alsactl" ]; then mkdir -p /home/ldesroches/buildroot_old/buildroot-2011.02/output/target/usr/share/; rm -rf /home/ldesroches/buildroot_old/buildroot-2011.02/output/target/usr/share/alsa/; cp -rdpf /home/ldesroches/buildroot_old/buildroot-2011.02/output/host/usr/arm-unknown-linux-uclibcgnueabi/sysroot/usr/share/alsa/ /home/ldesroches/buildroot_old/buildroot-2011.02/output/target/usr/share/alsa/; fi<BR>
cp: target `/home/ldesroches/buildroot_old/buildroot-2011.02/output/target/usr/share/alsa/' is not a directory: No such file or directory<BR>
make: *** [/home/ldesroches/buildroot_old/buildroot-2011.02/output/build/alsa-utils-1.0.23/.stamp_target_installed] Error 1<BR>
<BR>
I think it can be simply corrected with :<BR>
<BR>
--- package/multimedia/alsa-utils/alsa-utils.mk.orig    2011-03-08 11:21:21.000000000 +0100<BR>
+++ package/multimedia/alsa-utils/alsa-utils.mk 2011-03-07 17:35:05.000000000 +0100<BR>
@@ -49,7 +49,8 @@<BR>
        if [ -x "$(TARGET_DIR)/usr/sbin/alsactl" ]; then \<BR>
                mkdir -p $(TARGET_DIR)/usr/share/; \<BR>
                rm -rf $(TARGET_DIR)/usr/share/alsa/; \<BR>
-               cp -rdpf $(STAGING_DIR)/usr/share/alsa/ $(TARGET_DIR)/usr/share/alsa/; \<BR>
+               mkdir -p $(TARGET_DIR)/usr/share/alsa; \<BR>
+               cp -rdpf $(STAGING_DIR)/usr/share/alsa/* $(TARGET_DIR)/usr/share/alsa/; \<BR>
        fi<BR>
 endef<BR>
<BR>
<BR>
- the second one is about ncftp extraction part :<BR>
<BR>
>>> ncftp 3.2.4 Extracting<BR>
tar: win/bmed/bookmark.c: Cannot hard link to `ncftp-3.2.4/ncftp/bookmark.c': No such file or directory<BR>
tar: Error exit delayed from previous errors<BR>
make: *** [/home/ldesroches/buildroot_old/buildroot-2011.02/output/build/ncftp-3.2.4/.stamp_extracted] Error 2<BR>
<BR>
Manually, I have no problem to extract this archive. The problem seems to be a path problem since I have ncftp-3.2.4/win/bmed/bookmark.c and ncftp-3.2.4/ncftp/bookmark.c. Do you know how I can correct this problem ?<BR>
<BR>
<BR>
Best Regards,<BR>
Ludovic Desroches<BR>
</FONT>
</P>

</BODY>
</HTML>