<html xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
<meta name="Generator" content="Microsoft Word 11 (filtered medium)">
<style>
<!--
 /* Font Definitions */
 @font-face
        {font-family:Wingdings;
        panose-1:5 0 0 0 0 0 0 0 0 0;}
 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman";}
a:link, span.MsoHyperlink
        {color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {color:purple;
        text-decoration:underline;}
pre
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:10.0pt;
        font-family:"Courier New";}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:Arial;
        color:windowtext;}
@page Section1
        {size:612.0pt 792.0pt;
        margin:72.0pt 90.0pt 72.0pt 90.0pt;}
div.Section1
        {page:Section1;}
-->
</style>
</head>
<body lang="EN-US" link="blue" vlink="purple">
<div class="Section1">
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt">Hello,<o:p></o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt"><o:p> </o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt">I am new to buildroot and this group<o:p></o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt"><o:p> </o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt">I am working with the at91sam9260ek board and NAND Flash<o:p></o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt"><o:p> </o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt">Currently I am able to compile using buildroot kernel - Linux 2.6.34.1<o:p></o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt">I flashed the uImage at 0x200000 and root.jffs2 at 0x400000<br>
Also the uboot, uboot.env at 0x20000 and 0x60000 from the demo along with the at91bootstrap<o:p></o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt"><o:p> </o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt">When I boot, I get the following erroneous response
<br>
<br>
<o:p></o:p></span></font></p>
<p class="MsoNormal" style="text-indent:36.0pt"><font size="3" face="Times New Roman"><span style="font-size:12.0pt">rtc-at91sam9 at91_rtt.0: hctosys: unable to read the hardware clock<o:p></o:p></span></font></p>
<p class="MsoNormal" style="text-indent:36.0pt"><font size="3" face="Times New Roman"><span style="font-size:12.0pt">VFS: Cannot open root device "mtdblock0" or unknown-block(0,0)<o:p></o:p></span></font></p>
<p class="MsoNormal" style="text-indent:36.0pt"><font size="3" face="Times New Roman"><span style="font-size:12.0pt">Please append a correct "root=" boot option; here are the available partitions:<o:p></o:p></span></font></p>
<p class="MsoNormal" style="text-indent:36.0pt"><font size="3" face="Times New Roman"><span style="font-size:12.0pt">Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)<br>
<br>
<o:p></o:p></span></font></p>
<p class="MsoNormal" style="text-indent:36.0pt"><font size="3" face="Times New Roman"><span style="font-size:12.0pt"><o:p> </o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt">I tried with more numbers to mtdblock0/1/4 and mtd 0/1/4 etc  <o:p></o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt">Still I get the same error.<o:p></o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt"><o:p> </o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt">             VFS: Cannot open root device "mtd0" or unknown-block(0,0)<o:p></o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt"><br>
For info: <br>
bootcmd=nand read 0x22200000 0x00200000 0x00168CF8; bootm 0x22200000<br>
<br>
I also have made the mentioned changes in the at91sam9260ek_defconfig file for NAND ...
<br>
<br>
CONFIG_MTD=y<br>
CONFIG_MTD_PARTITIONS=y<br>
CONFIG_MTD_CHAR=y<br>
CONFIG_MTD_BLOCK=y<br>
CONFIG_MTD_NAND=y<br>
CONFIG_MTD_NAND_YOURBOARD=y<br>
CONFIG_JFFS2_FS=y<br>
CONFIG_JFFS2_FS_DEBUG=0<br>
CONFIG_JFFS2_FS_NAND=y<o:p></o:p></span></font></p>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt"><o:p> </o:p></span></font></p>
<pre><font size="2" face="Courier New"><span style="font-size:10.0pt">And of course </span></font><font face="Wingdings"><span style="font-family:Wingdings">à</span></font> setenv bootargs 'mem=64M console=ttyS0,115200 root=/dev/name_of_block_device rw rootfstype=jffs2'<o:p></o:p></pre>
<p class="MsoNormal"><font size="3" face="Times New Roman"><span style="font-size:
12.0pt"><br>
I cannot find my way out ....<br>
If any idea, then do let me know<br>
<br>
Thanks a lot.<br>
abhiash<o:p></o:p></span></font></p>
<p class="MsoNormal"><font size="2" face="Arial"><span style="font-size:10.0pt;
font-family:Arial"><o:p> </o:p></span></font></p>
</div>
<br>
<br>
__________ Hinweis von ESET NOD32 Antivirus, Signaturdatenbank-Version 5515 (20101008) __________<br>
<br>
E-Mail wurde geprüft mit ESET NOD32 Antivirus.<br>
<br>
<a href="http://www.eset.com">http://www.eset.com</a><br>
</body>
</html>