<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii">
<TITLE>Message</TITLE>

<META content="MSHTML 6.00.6000.16735" name=GENERATOR></HEAD>
<BODY>
<DIV><FONT face=Arial size=2>I have been having a problem with missing devices 
in buildroot for my&nbsp;<SPAN class=771275821-16122008>at91sam</SPAN>9g20 
design, specifically rtc0 and ppp. The kernel has ppp enabled and sets the rtt 
to rtc0. But the RFS does not have drivers for either in the /dev directory. 
Doing some research I found a file in buildroot called device_table.txt that 
looks like what I need to modify in order to&nbsp;<SPAN 
class=771275821-16122008>make these</SPAN> drivers<SPAN 
class=771275821-16122008> available</SPAN>&nbsp;in my build. One thing I am not 
sure of is which version of this file&nbsp;<SPAN class=771275821-16122008>I 
should modify</SPAN>. There is one in "target/generic" and also in 
"target/device/Atmel/root". Which one should I&nbsp;<SPAN 
class=771275821-16122008>change</SPAN>? Also, it is not clear to me if it is 
possible to have board specific device_table.txt files. Is that possible? And if 
so, how would I do it? </FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<P>
<DIV align=left><FONT face="Comic Sans MS" color=#000080 size=2>Timothy 
Barr<BR>Hardware Development Engineer<BR>for Multi-Tech Systems, 
Inc.</FONT><BR><A href="mailto:tbarr@multitech.com"><FONT face="Comic Sans MS" 
size=2>tbarr@multitech.com</FONT></A>
<P></P>
<P></P></DIV>
<P></P>
<DIV>&nbsp;</DIV></BODY></HTML>