All,<br><br>I have found that selecting:<br><br>(big endian)<br>BR2_armeb=y <br><br>with EABI + soft-float will NOT build correctly (svn revision: 20210)<br><br>It dies while building libmudflap (gcc).&nbsp; I set&nbsp; BR2_EXTRA_GCC_CONFIG_OPTIONS=&quot;--disable-libmudflap&quot; and this got me a bit further, but still died in gcc-final.
<br><br>I then found that if I set:<br><br>(little endian)<br>BR2_arm=y<br><br>with everything else the same everything builds fine.<br><br>BTW - I had the buildroot working with armeb + eabi + soft-float + gcc 4.1.2 quite a while back (svn revision: 18419).&nbsp; I ran into the above issue when I updated to svn revision 20210.&nbsp; I tried with both gcc 
4.1.2 and 4.2.1 and found that little endian (BR2_arm) works while (BR2_armeb) does not.&nbsp; I have set BR2_xscale=y, BR2_ARM_EABI=y and BR2_SOFT_FLOAT=y in all cases.<br><br>Regards,<br><br>Jon Nalley<br><br><div><span class="gmail_quote">
On 10/10/07, <b class="gmail_sendername">Gertjan Hofman</b> &lt;<a href="mailto:gertjan_hofman@yahoo.com">gertjan_hofman@yahoo.com</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Dear bernard,<br><br>Sorry for the slow response. Aside from a long weekend<br>here, it takes a while to run through various<br>compilations from scratch. I am never sure that the<br>various make cleans work properly so I often end up
<br>restarting a buildroot build from the tar file,<br>leading to long download &amp; compile times.<br><br>If I copy the&nbsp;&nbsp;integrator926_defconfig file as .config<br>the make indeed works fine. So I suspect it&#39;s your<br>
different uclibc config file which makes it work.<br><br>This is what I find difficult about BuildRoot - you<br>choose an option in make menuconfig and it has an<br>effect on a package that now needs a different config<br>
as well - but unless you familiarize your self with<br>each package and create config files seperately, this<br>is not a simple task.<br><br>I note your file compiles for EABI by default. I tried<br> setting back to OABI in the main config file and I
<br>would have expected BuildRoot to remake the tool<br>chain. It doesnt.<br><br>If I get any further I will post the information.<br><br>Gertjan<br><br><br><br><br><br><br><br><br>--- Bernhard Fischer &lt;<a href="mailto:rep.dot.nop@gmail.com">
rep.dot.nop@gmail.com</a>&gt; wrote:<br><br>&gt; On Thu, Oct 04, 2007 at 03:11:44PM -0700, Gertjan<br>&gt; Hofman wrote:<br>&gt; &gt;Don&#39;t want to report this as a bug if it&#39;s<br>&gt; not...but.<br>&gt; &gt;<br>&gt; &gt;Dowload 4-Oct-2007 version of buildroot. Choose ARM
<br>&gt;<br>&gt; Unfortunately this doesn&#39;t tell me what svn revision<br>&gt; that is, but this<br>&gt; doesn&#39;t really matter this time.<br>&gt;<br>&gt; &gt;processor, choose &#39;soft-float&#39; in make menuconfig.
<br>&gt;<br>&gt; Please note that this is not a crash but a<br>&gt; build-failure.<br>&gt;<br>&gt; I have a sample for an ARM integrator in target/Arm.<br>&gt; Can you check your settings against this one and<br>&gt; follow-up with your
<br>&gt; findings?<br>&gt;<br>&gt; TIA,<br>&gt;<br><br><br><br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;____________________________________________________________________________________<br>Tonight&#39;s top picks. What will you watch tonight? Preview the hottest shows on Yahoo! TV.
<br><a href="http://tv.yahoo.com/">http://tv.yahoo.com/</a><br><br>_______________________________________________<br>buildroot mailing list<br><a href="mailto:buildroot@uclibc.org">buildroot@uclibc.org</a><br><a href="http://busybox.net/mailman/listinfo/buildroot">
http://busybox.net/mailman/listinfo/buildroot</a><br></blockquote></div><br>