All,<br><br>I am attempting to add libxslt to the packages under buildroot.  It fails with the following errors:<br><br>/home/dmfrey/dev/embedded<div>/gumstix-buildroot/build_arm_nofpu/staging_dir/bin/arm-linux-uclibcgnueabi-gcc
-shared  .libs/attrvt.o .libs/xslt.o .libs/xsltutils.o .libs/pattern.o
.libs/templates.o .libs/variables.o .libs/keys.o .libs/numbers.o
.libs/extensions.o .libs/extra.o .libs/functions.o .libs/namespaces.o
.libs/imports.o .libs/attributes.o .libs/documents.o .libs/preproc.o
.libs/transform.o .libs/security.o  -L/usr/lib /usr/lib/libxml2.so -lm 
-march=armv5te -mtune=xscale -Wl,-soname -Wl,
libxslt.so.1 -o .libs/libxslt.so.1.1.21<br>/usr/lib/libxml2.so: could not read symbols: File in wrong format<br>collect2: ld returned 1 exit status<br>make[3]: *** [<a href="http://libxslt.la/" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">

libxslt.la</a>] Error 1<br>make[3]: Leaving directory `/home/dmfrey/dev/embedded/gumstix-buildroot/build_arm_nofpu/libxslt-
1.1.21/libxslt'<br>make[2]: *** [all-recursive] Error 1<br>make[2]: Leaving directory `/home/dmfrey/dev/embedded/gumstix-buildroot/build_arm_nofpu/libxslt-1.1.21'<br>make[1]: *** [all] Error 2<br>make[1]: Leaving directory `/home/dmfrey/dev/embedded/gumstix-buildroot/build_arm_nofpu/libxslt-
1.1.21'<br>make: *** [/home/dmfrey/dev/embedded/gumstix-buildroot/build_arm_nofpu/libxslt-1.1.21/libxslt.so] Error 2<br><br><br>I used the xml2 <a href="http://config.in/" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">

Config.in</a> and <a href="http://xml2.mk/" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">xml2.mk
</a> as a model for setting up libxslt.  I am building on ubuntu
feisty.  If there is any other info required, please let me know; I
have attached my two files in the xslt directory under package.  I am
not totally sure as to what is going on here, but I think it has
something to do with the fact that libxml2 was compiled for my host
architecture.  When I see the ouput fly by, it is finding the local
systems libxml2.27, versus the libxml2.29 in the buildroot.<br><br>Thanks for any help.</div>
<br><br>